Author Topic: PhotoMechanic crashing plus Combined orange and 3 star tagging sometimes  (Read 1745 times)

Offline tonyparreiro

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Hi,

Photo Mechanic 5 build 13764. Windows 7 64bit with 6Gb memory.

I have been running the evaluation of the software for a couple of weeks and will trying to go through 7300+ images it seems to crash after quickly going through images, not sure exactly how many but have noticed that if I slow down it hasn't crashed on me yet but this then defeats the purpose a little bit.

The other problem seems to be that when I use the Alt-3 hotkey to tag an image as 3 star it sometimes also tags it as Orange which is just the 3 hotkey, now I thought maybe I'm getting a bit out of synch but have tried to slow down and although the problem is less it still occurs.

Any ideas? Am I doing something wrong?

Thanks,
Tony

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Tony,

Photo Mechanic 5 build 13764. Windows 7 64bit with 6Gb memory.

I have been running the evaluation of the software for a couple of weeks and will trying to go through 7300+ images it seems to crash after quickly going through images, not sure exactly how many but have noticed that if I slow down it hasn't crashed on me yet but this then defeats the purpose a little bit.

The speed at which you go through the images should not matter.  Perhaps there is a memory leak in Photo Mechanic that causes the exhaustion of memory and thus the application crashes.  Photo Mechanic is a 32-bit application so its address space is limited to far less than your 6GB of memory.  So you have 7300 (or more) images in a single folder?  While that is a large number of photos, PM should be up to the task.

Are you seeing the crash reporter appear when Photo Mechanic crashes?  Are you filing crash reports?

One thing you could do for informational purposes is to run the Windows Task Manager and keep an eye out for how much memory Photo Mechanic is using over time.  If it just keeps on climbing without end, then it is likely that it has a memory leak.  If it gains in size, but a few moments later reduces in size, then that is not likely to be the problem.

The other problem seems to be that when I use the Alt-3 hotkey to tag an image as 3 star it sometimes also tags it as Orange which is just the 3 hotkey, now I thought maybe I'm getting a bit out of synch but have tried to slow down and although the problem is less it still occurs.

Are you certain that you're pressing Alt first before you press the 3 key and keep Alt down until after you release the 3 key?

-Kirk
« Last Edit: March 12, 2013, 06:44:40 AM by Kirk Baker »

Offline tonyparreiro

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Hi Kirk,

Tony,

Photo Mechanic 5 build 13764. Windows 7 64bit with 6Gb memory.

I have been running the evaluation of the software for a couple of weeks and will trying to go through 7300+ images it seems to crash after quickly going through images, not sure exactly how many but have noticed that if I slow down it hasn't crashed on me yet but this then defeats the purpose a little bit.

The speed at which you go through the images should not matter.  Perhaps there is a memory leak in Photo Mechanic that causes the exhaustion of memory and thus the application crashes.  Photo Mechanic is a 32-bit application so its address space is limited to far less than your 6GB of memory.  So you have 7300 (or more) images in a single folder?  While that is a large number of photos, PM should be up to the task.

Are you seeing the crash reporter appear when Photo Mechanic crashes?  Are you filing crash reports?

One thing you could do for informational purposes is to run the Windows Task Manager and keep an eye out for how much memory Photo Mechanic is using over time.  If it just keeps on climbing without end, then it is likely that it has a memory leak.  If it gains in size, but a few moments later reduces in size, then that is not likely to be the problem.

I don't remember seeing any crash reporter, I think it was just the windows message saying the process has stopped but will take better note next time it happens. I will have a log more photos over this coming 4 days so will make sure I have Task Manager running when I try it again.

The other problem seems to be that when I use the Alt-3 hotkey to tag an image as 3 star it sometimes also tags it as Orange which is just the 3 hotkey, now I thought maybe I'm getting a bit out of synch but have tried to slow down and although the problem is less it still occurs.

Are you certain that you're pressing Alt first before you press the 3 key and keep Alt down until after you release the 3 key?

-Kirk


I had though of that and tried a few things to prove it one way or another and it still seemed to happen, but I guess I could just use the the colour tagging instead or reassign the keys maybe.

Thanks,
Tony