Author Topic: Need Help with Ingest  (Read 5764 times)

Offline MorganLynnPhoto

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Need Help with Ingest
« on: May 16, 2013, 03:38:02 PM »
PM 5 Build 13915 on Win 7 64 bit

I've been having an issue with slow ingests ever since I installed PM 5. I thought I had solved the problem by uninstalling PM 5 and reverting to 4.6.9, but I was mistaken and the problem is the same.

In a nutshell, I ingest multiple CF cards at a time using the ingest feature. None of my preferences for ingesting have changed, but after I installed PM 5 my ingests would get gradually slower and slower as the ingest progressed. In other words, my ingest speed would start out normally (say ~100 images per minute) and then after about 5 minutes would be about half the speed (~50 images per minute) and so on and so on until about an hour or so I would only be ingesting 3-4 images per minute. I've tried playing with the cache, reinstalling PM, updating my USB drivers, etc..., but nothing has worked.

I can copy files over in windows explorer just fine.

Any help would be greatly appreciated.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Need Help with Ingest
« Reply #1 on: May 16, 2013, 06:16:58 PM »
PM 5 Build 13915 on Win 7 64 bit

I've been having an issue with slow ingests ever since I installed PM 5. I thought I had solved the problem by uninstalling PM 5 and reverting to 4.6.9, but I was mistaken and the problem is the same.

In a nutshell, I ingest multiple CF cards at a time using the ingest feature. None of my preferences for ingesting have changed, but after I installed PM 5 my ingests would get gradually slower and slower as the ingest progressed. In other words, my ingest speed would start out normally (say ~100 images per minute) and then after about 5 minutes would be about half the speed (~50 images per minute) and so on and so on until about an hour or so I would only be ingesting 3-4 images per minute. I've tried playing with the cache, reinstalling PM, updating my USB drivers, etc..., but nothing has worked.

I can copy files over in windows explorer just fine.

Any help would be greatly appreciated.

What kind of device are you Ingesting from?  Are you having PM show the items in a contact sheet while the Ingest is ongoing?

-Kirk

Offline MorganLynnPhoto

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Need Help with Ingest
« Reply #2 on: May 17, 2013, 08:06:41 AM »
Originally I was ingesting from a Delkin Imagerouter. After, I experienced the slow ingest issue, I purchased 4 Lexar USB 3.0 card readers and have them going to a powered USB HUB, which did not fix the problem.... If I try to ingest 1 card at a time, the first card will start the ingest fine (say ~100 images/min)  and then gradually get slower (down to ~40 images/min). Once the first card completes and I put the next card, it will start ingesting at the same rate that the first card left off (~40 images/min) and slow down more (~20 images/min) at the end and the third card will go more slowly than the second and so on until the ingest is ridiculously slow (3-4 images per minute).

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Need Help with Ingest
« Reply #3 on: May 17, 2013, 08:10:51 AM »
Originally I was ingesting from a Delkin Imagerouter. After, I experienced the slow ingest issue, I purchased 4 Lexar USB 3.0 card readers and have them going to a powered USB HUB, which did not fix the problem.... If I try to ingest 1 card at a time, the first card will start the ingest fine (say ~100 images/min)  and then gradually get slower (down to ~40 images/min). Once the first card completes and I put the next card, it will start ingesting at the same rate that the first card left off (~40 images/min) and slow down more (~20 images/min) at the end and the third card will go more slowly than the second and so on until the ingest is ridiculously slow (3-4 images per minute).

How many images in total?

Are you having PM show the items in a contact sheet while the Ingest is ongoing?

Does the rest of your computer get slower?

How much RAM do you have in your system?

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Need Help with Ingest
« Reply #4 on: May 17, 2013, 08:11:36 AM »
In addition to Kirk's questions: Does the speed drop when using Windows explorer to copy files too?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline MorganLynnPhoto

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Need Help with Ingest
« Reply #5 on: May 17, 2013, 08:44:27 AM »
Sorry forgot to answer that earlier. Yes, the images are displaying while the ingest is happening.

6 Gb of RAM

In Windows explorer the ingest rate doesn't change and stays around ~120 images per minute through the entire card

I would say once there are around 1000 images ingested the files are ingesting at around 40/min. After about 2000 images are ingested the files are ingesting at around 15/min.... As far as the total number we ingest it varies, but is in the thousands. Lately, I have just been pulling them in manually though (windows explorer) because after about 3000 images are ingested it's going super slow (3-4 images/min).
« Last Edit: May 17, 2013, 09:47:05 AM by MorganLynnPhoto »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Need Help with Ingest
« Reply #6 on: May 17, 2013, 11:15:44 AM »
Sorry forgot to answer that earlier. Yes, the images are displaying while the ingest is happening.

6 Gb of RAM

In Windows explorer the ingest rate doesn't change and stays around ~120 images per minute through the entire card

I would say once there are around 1000 images ingested the files are ingesting at around 40/min. After about 2000 images are ingested the files are ingesting at around 15/min.... As far as the total number we ingest it varies, but is in the thousands. Lately, I have just been pulling them in manually though (windows explorer) because after about 3000 images are ingested it's going super slow (3-4 images/min).

If you don't have PM view the images as they're ingested, does the speed still decrease?

It's really not fair to compare speed of transfer when you're forcing PM to also scan/sort/decode/display images at the same time against Windows Explorer which is only copying the images without processing any of the file metadata or displaying and sorting the images.

What sort type are you using in your contact sheets by default?

-Kirk

Offline MorganLynnPhoto

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Need Help with Ingest
« Reply #7 on: May 19, 2013, 12:28:31 PM »
If I don't display the images the ingest seems to work normally!  It's strange because I've always displayed the images in the past with no problems, but I'll take the result, thank you!