Author Topic: PM hangs when using network drive  (Read 15546 times)

Offline dtemp

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: PM hangs when using network drive
« Reply #15 on: February 01, 2007, 08:33:33 AM »
I'm wondering if there's been any update to this issue, or any workarounds (it was alluded to that the sort method might have something to do with it?).

I know it would take a whole rewrite of the code, but removing this from the "event thread" or whatever so this sort is done in the background (as opposed to grinding the program to a halt) might be ideal for the next major version of PM...

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: PM hangs when using network drive
« Reply #16 on: February 01, 2007, 10:10:24 PM »
I'm wondering if there's been any update to this issue, or any workarounds (it was alluded to that the sort method might have something to do with it?).

I know it would take a whole rewrite of the code, but removing this from the "event thread" or whatever so this sort is done in the background (as opposed to grinding the program to a halt) might be ideal for the next major version of PM...

Not yet.  I would be happy to work with you on this issue to make a fix for the first minor update to version 4.5.  Right now I am stretched too thin trying to finish up version 4.5 for a mid-February release.

-Kirk

Offline dtemp

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: PM hangs when using network drive
« Reply #17 on: February 04, 2007, 01:43:25 PM »
Kirk, I will be around the server in question for one week in march.  (I'm currently telecommuting from 300 miles away.)  If my end of the testing process takes a week or less, then I would be happy to help.  Let me know!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: PM hangs when using network drive
« Reply #18 on: February 04, 2007, 02:54:53 PM »
Kirk, I will be around the server in question for one week in march.  (I'm currently telecommuting from 300 miles away.)  If my end of the testing process takes a week or less, then I would be happy to help.  Let me know!

OK, so contact me privately about three days before you'll be there and I'll get a special build ready for you.  Also give me your full name (I'm guessing your real name isn't "dtemp" in real life) and phone numbers where I can reach you.

Thanks,

-Kirk

Offline abennett

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM hangs when using network drive
« Reply #19 on: May 03, 2007, 01:02:33 AM »
I'm having the same troubles as described here; I'm wondering if there was any resolution? A few things that I've noticed are
- The delay seems worse if the network folder has a large number of images (100+) but this could be an illusion.
- The delay is worse on slower network (which seems obvious). I.e., 802.11g vs. 1000BaseT copper.
- Happens on both the Windows and Mac side for me. Spinning ball or hourglass.
- It only seems to happen on switching focus of the contact sheet.
- The first time the folder is open, it opens fast and gets image previews quickly (for reading from the network albeit)

I haven't timed anything, but the delay is unbearable to work with images from a network drive.
I'm using PM 4.4.3.3 on a Quad MacPro and MacBook Pro and PM 4.5 with Bootcamp running WinXP.
I haven't had much need to adjust preferences except to up the cache settings a little (512mb disk/256mb memory).
--Aaron

Offline isdoo

  • Newcomer
  • *
  • Posts: 15
    • View Profile
Re: PM hangs when using network drive
« Reply #20 on: May 03, 2007, 10:34:48 AM »
We have also noticed this - a direct cable connection is just as slow as a wireless connection :(

No speed issues if the photos are local.

Running XP on both laptops

Offline abennett

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM hangs when using network drive
« Reply #21 on: May 03, 2007, 05:36:38 PM »
An update from before. The delay is directly proportional to the number of images in the network directory.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: PM hangs when using network drive
« Reply #22 on: May 04, 2007, 07:08:16 AM »
Hello Everyone,

I have just created a logging version of the Photo Mechanic 4.5.1 beta for Windows.  If you're interested in helping me solve this issue, then please contact me privately (by clicking on my name to the left of this message) for the download link and instructions on how to send me the log files that are generated.

Thanks,

-Kirk

Offline muzdav

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • Murray Davidson Photography
Re: PM hangs when using network drive
« Reply #23 on: October 16, 2007, 05:28:30 AM »
Has there been any resolution to this issue yet?  I have the same issues on an XP machine and generally avoid using PM across my network because it's painfully slow.

Murray

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: PM hangs when using network drive
« Reply #24 on: October 16, 2007, 06:54:04 AM »
Murray,

Has there been any resolution to this issue yet?  I have the same issues on an XP machine and generally avoid using PM across my network because it's painfully slow.

Yes, please try the 4.5.3 beta available in the Announcements section.

-Kirk

Offline muzdav

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • Murray Davidson Photography
Re: PM hangs when using network drive
« Reply #25 on: October 16, 2007, 06:57:39 AM »
Cheers Kirk.  I'll give it a go.