Author Topic: Problems with handling ITPC batch processing  (Read 4354 times)

Offline Ready

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Problems with handling ITPC batch processing
« on: July 03, 2013, 07:02:02 AM »
Hi there

I'd like to update to the new PM version.
But I still have problems with handling ITPC batch processing on some images in large folders.
I get frequent error messages saying "There were errors during the apply to selected operation".
There were no scanned images, no TIFF, no movie nor mpg files, just some PS and out-of-the-box Iphone pictures.
As it seems it's the PS reworked files that show problems.
How overcome this issue?

Thnks


romano

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24222
    • View Profile
    • Camera Bits, Inc.
Re: Problems with handling ITPC batch processing
« Reply #1 on: July 03, 2013, 08:30:59 AM »
Romano,

Do you have any specific images that cannot be updated with IPTC/XMP information?  Can you post one here?

When you say 'large folders', what quantity of images are you talking about?

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Problems with handling ITPC batch processing
« Reply #2 on: July 03, 2013, 10:58:45 AM »
Hi Romano,

I just downloaded your images and tried to apply a the stationary pad to them. I too get the error and am unable to apply the metadata.

I tried resaving the image in Photoshop, but even that did not help. What did work was to re-save the image as a tif; I was then finally able to apply the metadata.

Funnily enough though, saving the tif back as jpg again also prevented photomechanic from applying the metadata‚Ķ There must be something odd about the file, but inspecting it with exiftool did not show anything obviously wrong.  :-\

Hopefully Kirk and the team can find something.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Ready

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: Problems with handling ITPC batch processing
« Reply #3 on: July 03, 2013, 11:44:34 AM »
Danke Hayo you for trying!
I've had similar problems with big Epson-Scan-Tiffs ;-)
Never was able to solve the issue.
images © romano p. riedo | FOTOPUNKT.CH
;-)

r.

Offline dennis

  • President
  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 458
    • View Profile
    • Camera Bits, Inc.
Re: Problems with handling ITPC batch processing
« Reply #4 on: July 03, 2013, 05:55:08 PM »
Hi Romano,

Long story but there is a solution.

The problem is due to an abnormally large chunk of data in the Photoshop JPEG marker for "MacintoshNSPrintInfo".  Photoshop 5 likes to add this "Photoshop resource" and it is really large (e.g. for an EPSON Stylus Pro). In fact it is so large that it blows the 64K limit on JPEG markers and so Photoshop 5 continues the data into a second Photoshop JPEG marker.  Unfortunately, Photo Mechanic isn't capable of dealing with this situation where a massive amount of Photoshop resources fill up the 64K block.

There are two solutions.  One solution is to resave these as new JPEGs in Photo Mechanic.  PM will then strip this extra data and then the IPTC-IIM data which lives in the Photoshop JPEG marker can be updated since the Photoshop JPEG marker is reduced to a more realistic size.  In your case, there does exist an (old style) IPTC-IIM resource but it only has date and time and our PM prefs string.  This solution isn't optimal since PM would need to re-compress the JPEG data and it could take a while to process.  The good thing is that this "save as" creates a completely separate file which won't affect the original, but again it will double the number of files so you would likely want to delete (or archive) the originals.

The second (preferred) solution is to set your IPTC/XMP preference to NOT add embedded IPTC (i.e. old-style IPTC-IIM).  See attached screen shot for the checkbox you want to turn off.  This will prevent PM from trying to add IPTC-IIM data to this max-sized Photoshop JPEG marker (which is what is causing the current failure - "no more room").  However, if there is already existing IPTC-IIM data then PM will try to update it even though this preference says not to add IPTC.  So therefore you first need to delete this IPTC metadata using the Tools menu command Delete Metadata and check ONLY the box "IPTC".  This can be done in a batch.  Then any subsequent edit of IPTC-XMP only will successfully update the file with the current XMP standards.  Since this affects the original file I would test this on COPIES of your originals first.  It seemed to work fine with the "TE AMO" sample you posted.  This procedure will also have the effect of preserving the print information (necessary?) which may be desirable, but any subsequent user of PM (if there were others) would also need to make sure their preferences also don't try to add IPTC.

Hope that helps!

BTW - It would be nice to have Photoshop just delete their print settings info as a batch.  Does anyone know how to do that with a droplet?

--dennis


[attachment deleted by admin]

Offline Ready

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: Problems with handling ITPC batch processing
« Reply #5 on: July 03, 2013, 07:53:15 PM »
Thanks a lot, Dennis.
I think I got it.
I'm not sure, if this over 64 K only happened with images I've printed. I'll look this up or think about ...
Now as you suggested it would be nice to force PS to avoid this stuff - or find a script doing this in a batch.

romano
« Last Edit: July 03, 2013, 07:56:22 PM by Ready »