Author Topic: Not able to send photos via email  (Read 10195 times)

Offline cdavisjr

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Not able to send photos via email
« on: December 17, 2006, 09:14:27 AM »
A progress bar appears after selecting "Send photos via email..." from the File Menu and the Apple Mail program opens, but nothing to indicated that the photos were send... I checked the box to "Review email in application before sending" and choose "Mail"  for "Send email via"...  Running Mac OSX 10.4.8... What am I missing, if anything?

Thanks,
Carl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21708
    • View Profile
    • Camera Bits, Inc.
Re: Not able to send photos via email
« Reply #1 on: December 17, 2006, 10:18:33 AM »
Carl,

A progress bar appears after selecting "Send photos via email..." from the File Menu and the Apple Mail program opens, but nothing to indicated that the photos were send... I checked the box to "Review email in application before sending" and choose "Mail"  for "Send email via"...  Running Mac OSX 10.4.8... What am I missing, if anything?

What version of Photo Mechanic are you running?  Did an email window appear in the Mail application?

-Kirk

Offline cdavisjr

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Not able to send photos via email
« Reply #2 on: December 17, 2006, 05:16:10 PM »
Kirk,

I'm running version 4.4.3.3 of Photo Mechanic..  Yes, a regular email window comes up after I "ok" the "Send photos via email" dialog window.. I don't see any indication of the email with the photos that I selected to send out..

--Carl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21708
    • View Profile
    • Camera Bits, Inc.
Re: Not able to send photos via email
« Reply #3 on: December 17, 2006, 06:54:26 PM »
Carl,

I'm running version 4.4.3.3 of Photo Mechanic..  Yes, a regular email window comes up after I "ok" the "Send photos via email" dialog window.. I don't see any indication of the email with the photos that I selected to send out..

Ok.  Open up the Console application (Applications/Utilities/Console.app) and see if it has any messages in it related to Photo Mechanic.  If so, post them back here.

Thanks,

-Kirk

Offline cdavisjr

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Not able to send photos via email
« Reply #4 on: December 18, 2006, 02:38:43 AM »
Kirk,

This is what I found in the Console application relating to Photo Mechanic..

===== Display starts at offset 77261 within file of length 208333. ====
===== Use File->Reload (Cmd-R) to display more. ====
2006-12-16 04:32:11.600 Photo Mechanic[6257] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x668dc00 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)
2006-12-16 19:13:01.580 Photo Mechanic[16256] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x531d500 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)
2006-12-17 20:40:17.202 Photo Mechanic[7045] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x1402fc0 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)

Thanks,
--Carl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21708
    • View Profile
    • Camera Bits, Inc.
Re: Not able to send photos via email
« Reply #5 on: December 18, 2006, 06:40:18 AM »
Carl,

This is what I found in the Console application relating to Photo Mechanic..

===== Display starts at offset 77261 within file of length 208333. ====
===== Use File->Reload (Cmd-R) to display more. ====
2006-12-16 04:32:11.600 Photo Mechanic[6257] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x668dc00 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)
2006-12-16 19:13:01.580 Photo Mechanic[16256] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x531d500 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)
2006-12-17 20:40:17.202 Photo Mechanic[7045] CFLog (22): Cannot find function pointer pluginFactory for factory 053918F4-2869-11D7-A671-000A27E2DB90 in CFBundle/CFPlugIn 0x1402fc0 </Users/carldavisjr/Library/Contextual Menu Items/ToastIt.plugin> (bundle, loaded)

Can you tell me what "ToastIt.plugin" is?  It appears to be the cause of the problem you're having.  Can it be temporarily removed and then you could try emailing again from Photo Mechanic?

-Kirk

Offline cdavisjr

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Not able to send photos via email
« Reply #6 on: December 18, 2006, 04:15:14 PM »
Kirk,

I have no idea what "ToastIt.plugin" would be. But I removed it to the Desktop and restarted the computer and then tried emailing a photo from Photo Mechanic which brought up the Mail application email window without any trace of the photo that I tried to send from Photo Mechanic. I also opened the Console application and this time there was nothing there relating to Photo Mechanic..

--Carl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21708
    • View Profile
    • Camera Bits, Inc.
Re: Not able to send photos via email
« Reply #7 on: December 18, 2006, 04:48:26 PM »
Carl,

I have no idea what "ToastIt.plugin" would be. But I removed it to the Desktop and restarted the computer and then tried emailing a photo from Photo Mechanic which brought up the Mail application email window without any trace of the photo that I tried to send from Photo Mechanic. I also opened the Console application and this time there was nothing there relating to Photo Mechanic..

Strange.  The only thing I can offer is to call you on the phone and see if I can help you more directly.  Contact me with a personal message by clicking on my name to the left of this message.  Give me your phone number and a best time to call (I'm in California.)

-Kirk

Offline cdavisjr

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Not able to send photos via email
« Reply #8 on: December 18, 2006, 04:54:58 PM »
Kirk,

I experimented some more and now it works, but don't know what the problem was or what made it work now... I returned the "ToastIt.plugin" to the Contextual Menu Items Folder and restarted and this time the photos appeared in the Mail app window as it should. I also re-checked the Console and see nothing in there related to Photo Mechanic.. Would this give you an idea what it might have been?

Thanks for your efforts in this matter and hope I won't have to ask again <g>..

--Carl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21708
    • View Profile
    • Camera Bits, Inc.
Re: Not able to send photos via email
« Reply #9 on: December 18, 2006, 04:58:14 PM »
Carl,

I experimented some more and now it works, but don't know what the problem was or what made it work now... I returned the "ToastIt.plugin" to the Contextual Menu Items Folder and restarted and this time the photos appeared in the Mail app window as it should. I also re-checked the Console and see nothing in there related to Photo Mechanic.. Would this give you an idea what it might have been?

No, not really, unfortunately.

I'm glad it's working for you now.  The Send Photos via Email function works really well for most people.

-Kirk

Offline SamFrost

  • Full Member
  • ***
  • Posts: 241
    • View Profile
    • Sam Frost Photography
Re: Not able to send photos via email
« Reply #10 on: December 18, 2006, 05:09:49 PM »
The ToastIt plugin provides a contextual menu item to burn things to disc with Roxio Toast.