Author Topic: Lags during captioning on mavericks  (Read 7580 times)

Offline fastgrapher

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Lags during captioning on mavericks
« on: October 26, 2013, 08:47:50 AM »
Hi,

Today i noticed some issues with PM on 10.9.
It lags while writing into the caption field.
I write, but it lasts a few seconds until the words appear.

The version I'm using is 5.0, build 13915 (a16ea99)

*edit#1*
I think i can figure out whats the problem:
Everytime I start a new word, there's a lag. Maybe because PM uses to search in the autocomplete (only about 25 lines long) and that causes the lag.
BUT I know that I didnt had the problem on OS X.8

*edit#2*
I resetted the Preferences but after loading my autocomplete set the lags appear again.

Greets,
Fg
« Last Edit: October 26, 2013, 09:03:28 AM by fastgrapher »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #1 on: October 27, 2013, 05:42:24 PM »
Verified reproducible.

We've got a new build coming, probably tomorrow.  It is unlikely I'll be able to fix it for the next build.  But once I do fix the problem we'll release a new build immediately.

In the meantime, you can turn off the autocomplete.

-Kirk

Offline fastgrapher

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Lags during captioning on mavericks
« Reply #2 on: October 30, 2013, 01:44:08 AM »
Hi Kirk,

thanks for solving the problem in the latest version!
now autocomplete is usable again. not completely lagfree but its ok!

Thank you and have a good time!

fg

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #3 on: October 30, 2013, 06:26:40 AM »
thanks for solving the problem in the latest version!
now autocomplete is usable again. not completely lagfree but its ok!

Hmm.  Under what circumstances does it lag now?  I can't get it to lag at all on my system.  And just FYI, the lag is coming from the OS, and not from PM.  The way I avoid the lag is by avoiding calling Apple's "complete:" method unless the number of letters before the cursor position are equal to your preferred Autocomplete letter count setting.  If I don't call their method then there is no lag at all.  But when I call their method with only one letter before the cursor position they take up to 500 milliseconds to produce their candidate list of completions.  This lag appears to go away when I call their method with two letters (changing the setting to even more letters limits the number of possible completions significantly).

So you should either be able to change your preference to more letters (which means you won't see the completion popup coming up as often and PM won't be calling Apple's "complete:" method as often) or you can change it to require F5 being pressed which will only bring up the completion popup when you press F5.  Either choice will very likely eliminate the lag altogether.

Otherwise, I can't make the OS do its work faster than it is capable of doing.  It is odd to me that "complete:" is that much slower on the new OS than previous revisions including the now ancient 10.6 who's "complete:" implementation is instantaneous, even for one letter.

-Kirk

-Kirk

Offline fastgrapher

  • Newcomer
  • *
  • Posts: 44
    • View Profile
Re: Lags during captioning on mavericks
« Reply #4 on: October 30, 2013, 07:36:28 AM »
Hi Kirk,

don't see that as a complaint! Typing now works but it doesnt feel 100% smooth.
I'm very glad you were able to patch it in this version, because autocomplete is highly used in my workflow!

And yeah, I trust you, that the issue is caused by the OS because only the switch to Mavericks caused the problem!

Fg

Offline François

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Lags during captioning on mavericks
« Reply #5 on: October 31, 2013, 05:15:40 PM »
Hi Kirk

There 's always lags when I'm writing IPTC fields, even after installing the last Photo Mechanic Version 5.0, build 15011 (54772e6) on OS X 10.9 Maverick. I also noticed lags on OS X Lion with PM previous build.

As I'm typing quickly, it's very uncomfortable to work. I don't need Autocomplete so it's always off.

I'm thinking to go back to Photo Mechanic 4.6 where there is no issue.

François

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #6 on: November 01, 2013, 10:13:11 AM »
François,

There 's always lags when I'm writing IPTC fields, even after installing the last Photo Mechanic Version 5.0, build 15011 (54772e6) on OS X 10.9 Maverick. I also noticed lags on OS X Lion with PM previous build.

As I'm typing quickly, it's very uncomfortable to work. I don't need Autocomplete so it's always off.

I'm thinking to go back to Photo Mechanic 4.6 where there is no issue.

If you had similar Autocomplete settings on your 4.6.x version, I would expect it to have more lags than build 15011 has.  The function causing the lag is part of the OS, and 15011 avoids calling the function whenever possible.  Earlier builds of PM 5, and PM 4.6.x for certain, call the "complete:" function each time you type a letter.  I don't see how going back to PM 4.6.x would be beneficial even if you disable Autocomplete entirely (or set it to need F5 to be pressed) because you would be missing out on all of the new features of PM 5 as well.

So I'm not understanding your logic unless you don't own a license of PM 5 already and don't find the new features and other speed enhancements worthwhile.

-Kirk

Offline François

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Lags during captioning on mavericks
« Reply #7 on: November 01, 2013, 01:17:03 PM »
I purchased a PM 5 licence about on year ago and that was a crucial tool for me until a few days, when I noticed lags when typing captions. I'm disappointed because nobody seems to have a solution to resolve this issue, that definitely slows my workflow.

I'm ready to do without PM 5 new features and get PM 4,6, but it's not working since I upgrade on OS 10,9 Maverick... the developer isn't recognized.  :(

PM was the perfect way to edit my pictures, I don' know yet another software like it. Do other people have the same issue ?

Kirk is there any solution ?

Best

François

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #8 on: November 01, 2013, 01:47:08 PM »
François,

I purchased a PM 5 licence about on year ago and that was a crucial tool for me until a few days, when I noticed lags when typing captions. I'm disappointed because nobody seems to have a solution to resolve this issue, that definitely slows my workflow.

I'm ready to do without PM 5 new features and get PM 4,6, but it's not working since I upgrade on OS 10,9 Maverick... the developer isn't recognized.  :(

If you don't have PM 4.6.9 running on your Mac OS X 10.9 system, how do you know that it won't also have the same lag issues when using Autocomplete?  And if you're planning to disable Autocomplete then why wouldn't you just stick with PM 5 and disable Autocomplete on it as well?

PM was the perfect way to edit my pictures, I don' know yet another software like it. Do other people have the same issue ?

You just need to set Gatekeeper to allow both Apple-recognized developers and AppStore apps.  PM 4.6.9 should work fine.

And there isn't any other software out there that is quite like Photo Mechanic. :)

-Kirk

Offline François

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Lags during captioning on mavericks
« Reply #9 on: November 01, 2013, 02:27:55 PM »
PM 4,6,9 was running until I moved from OS X Lion to OS X 10,9 Mavericks. I now succeeded to launch it (Gatekeeper, thanks).

There's no lags when writting on PM 4.6, and Autocomplete is disabled, as on PM 5...

I'm sad going back to the old PM 4.6 but that's the only way I have now to write normally. :-\

Let me know if you have any solution.

François


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #10 on: November 01, 2013, 03:01:51 PM »
François,

PM 4,6,9 was running until I moved from OS X Lion to OS X 10,9 Mavericks. I now succeeded to launch it (Gatekeeper, thanks).

There's no lags when writting on PM 4.6, and Autocomplete is disabled, as on PM 5...

I'm sad going back to the old PM 4.6 but that's the only way I have now to write normally. :-\

Let me know if you have any solution.

It's hard to fix something when I can't reproduce it on one of my own systems.  I'd need your help in solving the problem.  I'd need for you to do some tests and sharing of log files.  Let me know if you're interested.

-Kirk

Offline François

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Lags during captioning on mavericks
« Reply #11 on: November 02, 2013, 05:20:01 AM »
Hi

I reinstalled Photo Mechanic Version 5.0, build 15011 (54772e6) and there always important lags when writting in the whole software, even when writting my licence key...

I'm interested with helping you to solve this problem and do some tests.

François

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Lags during captioning on mavericks
« Reply #12 on: November 02, 2013, 07:28:38 AM »
François,

I reinstalled Photo Mechanic Version 5.0, build 15011 (54772e6) and there always important lags when writting in the whole software, even when writting my licence key...

I'm interested with helping you to solve this problem and do some tests.

OK, great.  Starting next week, I will begin contacting you privately with instructions, links to test builds, etc.

Thanks,

-Kirk