Author Topic: Slow Down since upgrading  (Read 1160 times)

Offline tmronin

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Slow Down since upgrading
« on: February 08, 2014, 11:28:20 PM »
Hi there!

Since I upgraded to the new build (Photo Mechanic Version 5.0, build 15277 (0ebcc6a) on Mac 10.9.1), PM has been just slow and laggy.  I get pinwheel almost everytime I re-activate the PM window from finder, PS or whatever and simple tasks (copying medium size jpg to a folder) take a very long time (10-15 secs) and usually involve a pinwheel.  Just double clicking on a folder right now took 24 seconds with a pinwheel the entire time.

It didn't do this a couple builds ago - it's always been lean, mean and fast. 

any suggestions to bring it back to the Photo Mechanic I know and love?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20633
    • View Profile
    • Camera Bits, Inc.
Re: Slow Down since upgrading
« Reply #1 on: February 08, 2014, 11:38:48 PM »
Hi there!

Since I upgraded to the new build (Photo Mechanic Version 5.0, build 15277 (0ebcc6a) on Mac 10.9.1), PM has been just slow and laggy.  I get pinwheel almost everytime I re-activate the PM window from finder, PS or whatever and simple tasks (copying medium size jpg to a folder) take a very long time (10-15 secs) and usually involve a pinwheel.  Just double clicking on a folder right now took 24 seconds with a pinwheel the entire time.

It didn't do this a couple builds ago - it's always been lean, mean and fast. 

any suggestions to bring it back to the Photo Mechanic I know and love?

The build you have is the fastest build yet and it is definitely faster than builds going all the way back to the popular 13915 build from last May.  Have you tried restarting your computer lately?

-Kirk

Offline tmronin

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Slow Down since upgrading
« Reply #2 on: February 08, 2014, 11:53:53 PM »
hey Kirk!  was hoping you would pop in.

yeah.  I restart often, cleaned out about 50 gigs of space and talked nice to my powerbook before posting here.

I'll try a full restart, fix permissions and hope for the best.  I can honestly say that PM is my most used program in my day to day and would love it back to the speed I know and love.