Author Topic: Cannot rate/color/tag files  (Read 3667 times)

Offline Federer Photography

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Cannot rate/color/tag files
« on: February 16, 2014, 05:56:33 PM »
PM15277
Windows 8

In either preview mode or contact sheet view, I don't seem to be able to rate/rank/color/etc any of the photos.   I can delete them (delete key) and can rename them (Ctrl+M) but can't do any ranking/rating/etc.

When I try, an XMP sidecar file is created, but never with any info about the desired tags/colors/etc.  For example. this entry is always there, regardless of if I color something a winner or trash... or try to tag the file or not...etc:
Code: [Select]
photomechanic:ColorClass="0"
   photomechanic:Tagged="False"
   photomechanic:Prefs="0:0:0:002922"
   photomechanic:PMVersion="PM5"
   xmp:Rating="0"

I've rebooted as well as reinstalled. I've also tried running the program as administrator.


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Cannot rate/color/tag files
« Reply #1 on: February 16, 2014, 07:22:18 PM »
PM15277
Windows 8

In either preview mode or contact sheet view, I don't seem to be able to rate/rank/color/etc any of the photos.   I can delete them (delete key) and can rename them (Ctrl+M) but can't do any ranking/rating/etc.

When I try, an XMP sidecar file is created, but never with any info about the desired tags/colors/etc.  For example. this entry is always there, regardless of if I color something a winner or trash... or try to tag the file or not...etc:
Code: [Select]
photomechanic:ColorClass="0"
   photomechanic:Tagged="False"
   photomechanic:Prefs="0:0:0:002922"
   photomechanic:PMVersion="PM5"
   xmp:Rating="0"

I've rebooted as well as reinstalled. I've also tried running the program as administrator.

Where are your images stored?  What camera make/model produced the images?

-Kirk

Offline Federer Photography

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Cannot rate/color/tag files
« Reply #2 on: February 16, 2014, 08:23:22 PM »
Nikon D700; 14bit RAW files.

Located on desktop; with full rights to the folder.  They are not set to read-only.   Had been copied from camera to computer in 2009 and haven't been seen since.

Since the original post, I've tried to 'rate' jpgs... and it works.   I've also tried rating images from a Nikon D800 in a different folder and they don't rate on the first attempt, but do the second attempt. (ie: if I set to "winner" the first time, nothing happens... then if I set to "winner" again, it stays).  It seems there is another current thread talking about having to 'double-rate' to get it to take.   Could this be related?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Cannot rate/color/tag files
« Reply #3 on: February 16, 2014, 11:21:17 PM »
Nikon D700; 14bit RAW files.

Located on desktop; with full rights to the folder.  They are not set to read-only.   Had been copied from camera to computer in 2009 and haven't been seen since.

Since the original post, I've tried to 'rate' jpgs... and it works.   I've also tried rating images from a Nikon D800 in a different folder and they don't rate on the first attempt, but do the second attempt. (ie: if I set to "winner" the first time, nothing happens... then if I set to "winner" again, it stays).  It seems there is another current thread talking about having to 'double-rate' to get it to take.   Could this be related?

Yes, I think so.  The problem will be addressed in the next build.

-Kirk

Offline Federer Photography

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Cannot rate/color/tag files
« Reply #4 on: February 17, 2014, 11:07:11 AM »
ETA on that?

... or a work-around for me now?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Cannot rate/color/tag files
« Reply #5 on: February 17, 2014, 11:47:19 AM »
ETA on that?

... or a work-around for me now?

No workaround other than to do the operation twice like you have been doing.

We'll release a new build soon.  Probably by the end of the month.

-Kirk

Offline Federer Photography

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Cannot rate/color/tag files
« Reply #6 on: February 17, 2014, 04:13:42 PM »
... but for the D700 files (which amount to the majority of the files), I can't make any changes/ratings/colors.

Doing it twice isn't a huge problem.  But not being able to do it at all is kind of a big deal.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Cannot rate/color/tag files
« Reply #7 on: February 17, 2014, 04:27:59 PM »
... but for the D700 files (which amount to the majority of the files), I can't make any changes/ratings/colors.

Doing it twice isn't a huge problem.  But not being able to do it at all is kind of a big deal.

Agreed.  You have two choices.  You can downgrade to an older version (see the Announcement section for posts on each build) or you can wait until I have a new version ready for release.

The D700 is a fairly popular camera so I would expect many people having the problem you're experiencing but I'm not seeing a case (other than yours) that no amount of rating/tagging/color classification ends up with a positive result.  What do your IPTC/XMP settings look like?

Please post a JPEG screen shot of your settings to this thread.

Thanks,

-Kirk