Author Topic: Append feature in stationery pad not working.  (Read 4505 times)

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Append feature in stationery pad not working.
« on: August 14, 2014, 11:41:20 AM »
I'm using PM5 on a Mac with OS 10.9.4. When I create a stationery pad template, the append/prefix feature for the description/caption field is not working. I'm clicking on the box to activate the field, and then choosing append (or prefix), and then saving the .xmp tempplate. But then when I use the template, whatever I typed into the caption field is still replacing instead of appending. Why might this feature not be working?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #1 on: August 14, 2014, 12:04:17 PM »
I'm using PM5 on a Mac with OS 10.9.4. When I create a stationery pad template, the append/prefix feature for the description/caption field is not working. I'm clicking on the box to activate the field, and then choosing append (or prefix), and then saving the .xmp tempplate. But then when I use the template, whatever I typed into the caption field is still replacing instead of appending. Why might this feature not be working?

If you open up the IPTC Stationery Pad does it still have your settings?
When are you applying the IPTC Stationery Pad?  During Ingest?  Or some other time?

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #2 on: August 14, 2014, 12:39:27 PM »
Yes, it still has my settings, everything seems to work just fine except for that one feature. Not doing this on ingest -- I am dropping a folder of images on PM, opening a photo's IPTC info window, clicking load, selecting the template and clicking open. Everything from my template pops in fine, except that feature fails. I've experimented to discover that selecting (checking) and un-selecting the caption field box works properly, but selecting append, prefix or replace all have the same result -- replacement rather than addition. My IPTC info field view is a custom one that I created, don't know if that might have an effect.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #3 on: August 14, 2014, 12:56:46 PM »
Yes, it still has my settings, everything seems to work just fine except for that one feature. Not doing this on ingest -- I am dropping a folder of images on PM, opening a photo's IPTC info window, clicking load, selecting the template and clicking open. Everything from my template pops in fine, except that feature fails. I've experimented to discover that selecting (checking) and un-selecting the caption field box works properly, but selecting append, prefix or replace all have the same result -- replacement rather than addition. My IPTC info field view is a custom one that I created, don't know if that might have an effect.

Can you give me your IPTC Stationery Pad settings (.xmp file)?

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #4 on: August 14, 2014, 01:05:48 PM »
Sure, attached.

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #5 on: August 14, 2014, 03:07:19 PM »
Sure, attached.

Hmm.  Well it works properly for me.  I suggest calling our support folks.  They'll troubleshoot the issue with you.  +1 503-547-2888.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #6 on: August 18, 2014, 05:07:06 PM »
Thanks, I called that number and went through it with Tony, but didn't figure out anything new other than he suggested repairing disk permissions on my machine. However, after talking with him I discovered that if I open iptc stationery pad, load the desired template (previously made using the append feature), close the stationery, open the photo's iptc and THEN apply stationery pad, it works -- the info is appended. Before, I was simply opening the photo's iptc, clicking the load button, choosing the desired template and opening it, in which case the info was replaced instead of appended.

So is the append/prefix feature only designed to work when choosing a template via the "apply stationery pad" button? If so, that adds extra steps. Would be much more convenient if it also worked when applying a template directly by using the load button when you have the photo's iptc field up. I have several templates for different situations. Having to first load a template to the stationery, then open the photo and apply it every time I need a different template is annoying.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #7 on: August 18, 2014, 09:54:21 PM »
Thanks, I called that number and went through it with Tony, but didn't figure out anything new other than he suggested repairing disk permissions on my machine. However, after talking with him I discovered that if I open iptc stationery pad, load the desired template (previously made using the append feature), close the stationery, open the photo's iptc and THEN apply stationery pad, it works -- the info is appended. Before, I was simply opening the photo's iptc, clicking the load button, choosing the desired template and opening it, in which case the info was replaced instead of appended.

So is the append/prefix feature only designed to work when choosing a template via the "apply stationery pad" button? If so, that adds extra steps. Would be much more convenient if it also worked when applying a template directly by using the load button when you have the photo's iptc field up. I have several templates for different situations. Having to first load a template to the stationery, then open the photo and apply it every time I need a different template is annoying.

Generally people load into the IPTC Stationery Pad and then apply that pad to several files at once.  Is there no way for you to identify a set of images that would all need the same metadata applied to them?

IPT/XMP files loaded into the IPTC info "merge" into your current IPTC Info.  IPT/XMP files that are loaded into the IPTC Stationery Pad do not behave that way.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #8 on: August 19, 2014, 07:27:48 AM »
Sometimes but not always. Ours is a news images workflow where I'm working on folders of images that all go with a certain story, but sometimes they come from various sources and require different appends and prefixes to the caption, and therefore I may need to use 2 or 3 of my templates on different imgages within a single folder of photos. With the load button I can do that on the fly, so to speak, without having to close the iptc field, go to pad, load a different template, reopen the field, etc. Ufortunately it looks like the new append/prefix feature is lost when using load to bring in a template while in in an images' iptc field.

I also wish it was possible, when one has multiple contact sheets open from different folders of images, to also have multiple iptc fields open for each contact sheet. Was hoping that would come with PM5, but alas, seems not so, unless I'm just not seeing how to do it. I need to compare/fact check info in the iptc field from images in different folders sometimes, and I see no way to do that.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #9 on: August 19, 2014, 07:46:32 AM »
Sometimes but not always. Ours is a news images workflow where I'm working on folders of images that all go with a certain story, but sometimes they come from various sources and require different appends and prefixes to the caption, and therefore I may need to use 2 or 3 of my templates on different imgages within a single folder of photos. With the load button I can do that on the fly, so to speak, without having to close the iptc field, go to pad, load a different template, reopen the field, etc. Ufortunately it looks like the new append/prefix feature is lost when using load to bring in a template while in in an images' iptc field.

If you only have three templates, why not make a pass through your images, categorizing them into one of the three groups by putting a 1, 2, or 3 in some unused field?  Then when done, you could sort on that field (the images would group together).  Select each group, load the corresponding IPTC Stationery Pad and apply.  Have the IPTC Stationery Pad clear the unused field that you used for categorization.  This should be much faster than clicking the load button and selecting a file from a dialog each time.  You could also use color labels or star ratings for this categorization if you like that better.

I also wish it was possible, when one has multiple contact sheets open from different folders of images, to also have multiple iptc fields open for each contact sheet. Was hoping that would come with PM5, but alas, seems not so, unless I'm just not seeing how to do it. I need to compare/fact check info in the iptc field from images in different folders sometimes, and I see no way to do that.

No, you cannot have more than one IPTC Info or IPTC Stationery Pad dialog open at once and that will not likely ever change.

You can use the Info tooltips and use the variables for the fields you want to compare as your "Info Text".

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #10 on: August 19, 2014, 09:19:36 AM »
Thanks.

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #11 on: August 19, 2014, 09:30:41 AM »
Oh wait, I don't know what info tooltips refers to, I don't see that anywhere.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #13 on: August 19, 2014, 10:00:33 AM »
Ok, gotcha. Good to know about turning that feature on, but doesn't help. I need to compare the information in iptc fields like caption, photographer, city, country.

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #14 on: August 19, 2014, 10:05:49 AM »
Hah, sorry, right after my last msg I realized that I can choose other variables for the info text, like caption, that are not already there, so that does help a bit!