Author Topic: PM 5.0 build 15800 "Not Responding" when opening file list  (Read 2752 times)

Offline RETR_CB_Forum

  • Newcomer
  • *
  • Posts: 6
    • View Profile
PM 5.0 build 15800 "Not Responding" when opening file list
« on: August 17, 2014, 03:08:59 PM »
Hi I have the following issue which has started to happen in the last 2 weeks or so. I'm on Windows 7 Ultimate 32 bit and have been happily using PM for about 2 years but not intensively.

Whenever I now launch PM and click on the folder chooser I get a "not responding" message which even after several hours does not change.  I eventually have to kill PM with Windows Task Manager.  The Windows account I use to run this program is a Standard Windows account.  If I run PM with a different Windows Username either with Standard Windows permissions or Administrator Permissions, then PM opens folders & files almost instantly and operates as I've been used to.  I've even temporarily changed my normal account from a Standard to an Administrator Account but still get the "Not Responding" message. 

Clearly, something has happened when using this particular Windows account which is blocking the file/folder explorer function of PM. Help!

Thanks

Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23570
    • View Profile
    • Camera Bits, Inc.
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #1 on: August 17, 2014, 03:28:58 PM »
Richard,

Please try this build:

http://www.camerabits.com/download/PM5SetupR15821.exe

Please let me know if the problem goes away with this version.

Thanks,

-Kirk

Offline RETR_CB_Forum

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #2 on: August 18, 2014, 12:51:43 AM »
Kirk,

thank you so much.  It all works now with this release. What fantastic support - a reply in 20 minutes!

Kind regards

Richard

Offline bddorsey

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #3 on: August 21, 2014, 02:30:20 PM »
Kirk - i wanted to let you know that that build fixed a problem for me too.  everytime i switched back and forth to another application and then back to PM, PM would give me the spinning ring of death also.  this build seems to alleviate that.

Now if I you can just fix my "not responding" spinning ring that i get whenever i try to use the Navigator window I'll actually be in good shape.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23570
    • View Profile
    • Camera Bits, Inc.
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #4 on: August 21, 2014, 03:09:08 PM »
Kirk - i wanted to let you know that that build fixed a problem for me too.  everytime i switched back and forth to another application and then back to PM, PM would give me the spinning ring of death also.  this build seems to alleviate that.

Now if I you can just fix my "not responding" spinning ring that i get whenever i try to use the Navigator window I'll actually be in good shape.

Refresh my memory?  You're the one with a bunch of "disconnected" network drives or something like that?

-Kirk

Offline bddorsey

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #5 on: August 22, 2014, 07:48:44 AM »
Wow, Kirk -

That's an amazing memory you have.  Wish I had that.

Here's a recap:

It takes a full minute or so for PM to pull up the Navigator view.  And when the Nav window is left open, things can really hang up.  I've tried to get my team to stop using the Navigator window but they need to be able to open certain subfolders together in one tab and right now, this can only be done in the Navigator view.   Granted, we have 6 'connected' drives and maybe 5 large "disconnected" drives (we do this to trick lightroom into thinking they are local) and when one of them is expanded, there might be 50-75 project folders on that drive.

A couple of thoughts that might help...

1.  If we could use your "Open Folders and Subfolders in New Contact Sheet" or "Open in Current Contact Sheet" directly in the context sensitive System Explorer Menu or in the PM File>Open Contact Sheet... menu - we wouldn't even need to use the Navigator window at all.  This would be by far the best solution for us as it would give us flexibility to use PM directly from the System Explorer.

2.  Allow users to determine when the Navigator refreshes itself.  At least then,  we would only be stuck waiting the first time it opens.

3.  If there's a way to make it scan faster....

I've attached a pic of our file system hierarchy just fyi...

We REALLY appreciate your help on this.   We easily lose a good 2 full man-hours a week in our office on these PM hangups.  If there is anything I can do to help, just let me know.  Thanks.

And two other questions - if we have fully loaded desktop machines and go to open a folder containing say 4,000 RAW photographs for culling purposes what would be the best setup of PM Preferences in that situation to build thumbs as quickly as possible?  It seems that PM stops building thumbs if we move to another application so we can spend a great deal of time just waiting for the scan before we can change the sort (which we might need to do different ways each time).

Many many thanks again.





[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23570
    • View Profile
    • Camera Bits, Inc.
Re: PM 5.0 build 15800 "Not Responding" when opening file list
« Reply #6 on: August 22, 2014, 11:09:28 AM »
That's an amazing memory you have.  Wish I had that.

I wish I did too.  I went to your account and looked at your recent posts. ;)

Here's a recap:

It takes a full minute or so for PM to pull up the Navigator view.  And when the Nav window is left open, things can really hang up.  I've tried to get my team to stop using the Navigator window but they need to be able to open certain subfolders together in one tab and right now, this can only be done in the Navigator view.   Granted, we have 6 'connected' drives and maybe 5 large "disconnected" drives (we do this to trick lightroom into thinking they are local) and when one of them is expanded, there might be 50-75 project folders on that drive.

A couple of thoughts that might help...

1.  If we could use your "Open Folders and Subfolders in New Contact Sheet" or "Open in Current Contact Sheet" directly in the context sensitive System Explorer Menu or in the PM File>Open Contact Sheet... menu - we wouldn't even need to use the Navigator window at all.  This would be by far the best solution for us as it would give us flexibility to use PM directly from the System Explorer.

2.  Allow users to determine when the Navigator refreshes itself.  At least then,  we would only be stuck waiting the first time it opens.

3.  If there's a way to make it scan faster....

I've attached a pic of our file system hierarchy just fyi...

We REALLY appreciate your help on this.   We easily lose a good 2 full man-hours a week in our office on these PM hangups.  If there is anything I can do to help, just let me know.  Thanks.

Is there some reason you don't use the Favorites?  You can put the folders that you care about into it and it can also open folders and subfolders.  When you've moved on to a different project, you can just remove the unwanted items.

One note about your image though: you appear to have a large number of folders at the root of your drives.  I see that you're already naming them with the year as the prefix.  Why not put them into yearly folders?  That alone should help a lot.

That said, I do like the idea of making the PM Shell Menu offer to open folders and subfolders directly, but I'll have to look into whether that can be accomplished or not.

And one other question - if we have fully loaded desktop machines and go to open a folder containing say 4,000 RAW photographs for culling purposes what would be the best setup of PM Preferences in that situation to build thumbs as quickly as possible?  It seems that PM stops building thumbs if we move to another application so we can spend a great deal of time just waiting for the scan before we can change the sort (which we might need to do different ways each time).

The thing that makes the most difference is fast read access to your images.  Locally stored images load much faster than ones on network drives.  Settings-wise, I suggest setting the Memory cache to 512MB (I do not recommend making it any higher though.)  PM should load thumbnails in the background, but it may not be able to keep them all in memory (depending on your settings: thumbnail size, memory cache size, total number of items in the contact sheet) and may need to page the disk-cached thumbnails back into memory.

-Kirk