Author Topic: PhotoMechanic is not seeing all images in a folder  (Read 8295 times)

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
PhotoMechanic is not seeing all images in a folder
« on: September 01, 2014, 12:18:05 PM »
I'm on Version 5.0, Build 5800, and I'm running it on Windows 8.

When I open a folder through PhotoMechanic it's not showing all the photos in the folder. It's missing about 30. When I look in the actual folder on my PC  that I'm pointing PM to I see the photos there though so I know they're on my computer. Also all the files are RAW files if that makes any difference.

Any help ASAP would be much appreciated.

Thank you!

-Andrea

[attachment deleted by admin]

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: PhotoMechanic is not seeing all images in a folder
« Reply #1 on: September 01, 2014, 01:44:36 PM »
Looks fine to me; PM indicates that it has 4430+41=4471 files in the directory, exactly the number of files according to windows explorer.

There are two reasons PM might not show you the 41 “missing” files.
  • These are raw+jpg pairs. By default, PM only shows you one image for these.
  • These are unknown/non-image files.

In both cases, there's a specific option to have PM show them in the menu.

HTH,
Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24220
    • View Profile
    • Camera Bits, Inc.
Re: PhotoMechanic is not seeing all images in a folder
« Reply #2 on: September 01, 2014, 01:54:15 PM »
Andrea,

I'm on Version 5.0, Build 5800, and I'm running it on Windows 8.

When I open a folder through PhotoMechanic it's not showing all the photos in the folder. It's missing about 30. When I look in the actual folder on my PC  that I'm pointing PM to I see the photos there though so I know they're on my computer. Also all the files are RAW files if that makes any difference.

As Hayo pointed out, you have 41 unknown files in your folder.  Turn on the "Unknown files as proxies" setting in the View menu.

http://wiki.camerabits.com/en/index.php?title=User_Manual_Flat_View#View_Menu

Your unknown files will be represented by a generic icon.

-Kirk

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #3 on: September 01, 2014, 10:56:47 PM »
Hey! Thanks so much for replying! It appears I already have that option on.  :-\

[attachment deleted by admin]

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #4 on: September 01, 2014, 10:59:31 PM »
The other thing that's weird is that when I load the same folder into LR4 it sees all of the photos just fine and sees them as RAW files.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24220
    • View Profile
    • Camera Bits, Inc.
Re: PhotoMechanic is not seeing all images in a folder
« Reply #5 on: September 02, 2014, 06:35:56 AM »
Andrea,

What are the specific file names that don't appear in Photo Mechanic?

-Kirk

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #6 on: September 02, 2014, 11:04:38 AM »
Andrea,

What are the specific file names that don't appear in Photo Mechanic?

-Kirk


Basically file 3Z3A001 through 3Z3A0042 with 3Z3A0018 randomly thrown in.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: PhotoMechanic is not seeing all images in a folder
« Reply #7 on: September 02, 2014, 11:33:23 AM »
Try switching your PM sort order to "FileName", I bet you that you will find your files :D
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #8 on: September 02, 2014, 11:40:29 AM »
Try switching your PM sort order to "FileName", I bet you that you will find your files :D

Still missing.  :-\

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: PhotoMechanic is not seeing all images in a folder
« Reply #9 on: September 02, 2014, 12:47:03 PM »
Hmm, weird. What is the exact file type and extension of these files?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: PhotoMechanic is not seeing all images in a folder
« Reply #10 on: September 02, 2014, 12:51:20 PM »
Oh, and have you already made sure you are not filtering your files by accident? Press F1, and make sure you do not filter on colour class or star rating! The thing is, PM does know about those files, it just hides them somehow...
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24220
    • View Profile
    • Camera Bits, Inc.
Re: PhotoMechanic is not seeing all images in a folder
« Reply #11 on: September 02, 2014, 01:25:54 PM »
At this point I'd like to see a full directory listing showing the full file name with extension, please.

Thanks,

-Kirk

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #12 on: September 02, 2014, 04:54:18 PM »
Ok, here ya go.

At this point I'd like to see a full directory listing showing the full file name with extension, please.

Thanks,

-Kirk


[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24220
    • View Profile
    • Camera Bits, Inc.
Re: PhotoMechanic is not seeing all images in a folder
« Reply #13 on: September 02, 2014, 05:16:29 PM »
OK, thanks.  And what specific files don't show up?  (List full file name with extension, please.)

-Kirk

Offline BlueLacePhotography

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PhotoMechanic is not seeing all images in a folder
« Reply #14 on: September 02, 2014, 08:24:58 PM »
OK, thanks.  And what specific files don't show up?  (List full file name with extension, please.)

-Kirk


Hey there! I'm in a bit of an editing crunch right now so I don't have time to manually list all 43 file names but it starts with file 3Z3A0002.CR2 not showing up, 3Z3A0018.CR2 shows up, and then file 3Z3A0019.CR2 through 3Z3A0044.CR2 don't show up again in PM.

All the files are numbered in numeric order before the extension. I think in the first screen shot I posted you can see the files showing in the folder that's on my PC (you can't see the extension on those ones but I've verified that they are .CR2 files) , and I think you can see where PM is picking up which is at 3Z3A0045.CR2.