Author Topic: How to Block XMP files when using Ingest...!!  (Read 11432 times)

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
How to Block XMP files when using Ingest...!!
« on: November 22, 2014, 11:25:41 AM »
Hello,

When i Ingest my RAW files I noticed XMP files in my Foto folder in Fact I don't need them showing up How to block this I can't find anything in the Preferences I use Photo Mechanic  Version 5.0, build 16101 (2631961) for mac.

Import from card reader using Ingest XMP Files show up/ Dragging files from the card reader to Photo Mechanic on contact sheet No XMP files in my foto folder...!!

Any input I like to welcome.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20358
    • View Profile
    • Camera Bits, Inc.
Re: How to Block XMP files when using Ingest...!!
« Reply #1 on: November 22, 2014, 03:53:46 PM »
When i Ingest my RAW files I noticed XMP files in my Foto folder in Fact I don't need them showing up How to block this I can't find anything in the Preferences I use Photo Mechanic  Version 5.0, build 16101 (2631961) for mac.

Import from card reader using Ingest XMP Files show up/ Dragging files from the card reader to Photo Mechanic on contact sheet No XMP files in my foto folder...!!

If you don't want XMP sidecar files, the only other alternative for storing metadata is within the RAW file itself.  You can configure PM to embed XMP in your RAW files if you want to avoid XMP sidecar files.  If you don't want your RAW files to be modified and you don't want sidecar XMP files, you can't use Photo Mechanic for your metadata needs.

http://wiki.camerabits.com/en/index.php?title=User_Manual_Flat_View#IPTC.2FXMP_Preferences

-Kirk

Offline Frantisek Vlcek

  • Sr. Member
  • ****
  • Posts: 449
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #2 on: November 22, 2014, 04:05:34 PM »
Any PM Preferences to add some IPTC / resolution (dpi) or other info on Ingest? your workflow doesnt use xmp sidecars at all? What are your iptc preferences in PM? To be able to be compatible with various image editing programs, since not all of them cater to a common standard, PM can write image metadata in a variety of ways, some of which are mutually exclusive. Upon ingest, and depending on your settings, PM can (if I remember correctly) automatically create basic xmp sidecars to go along with the photos. Which would be preferred in some workflows. I assume you just have a wrong settings for your intended workflow. Or it might be a bug of course, but I would check the preferences first. There is a lightning button, "snapshot", in the IPTC prefs pane having several suggested options for best compatibility with different other editing software filled in. Or see the manual and forums for more detailed explanation. I would check these first , even though it seems you already did, there are some options in other pref panes which might affect it as well, and ingest options too.

Hope this helps

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #3 on: November 23, 2014, 01:06:43 AM »
Thanks for the input,
I looked at the preferences and I can't find anything to Embed the XMP file in the Raw file itself when Ingest, it keeps creating the Sidecar XMP file what ever changes I make.

Any way thanks..!!

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2465
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #4 on: November 23, 2014, 02:38:40 AM »
I looked at the preferences and I can't find anything to Embed the XMP file in the Raw file itself when Ingest, it keeps creating the Sidecar XMP file what ever changes I make.

Well, unless you started off with an xmp file, it sure is possible to have PM not create xmp files. My own workflow is (completely) free of xmp files. As I use DNG files, even Photoshop and Lightroom don't need them!

Have a look at the preferences I use to achieve this. Note though that you may want to change particular settings to fit your own workflow.

HTH,
Hayo

[attachment deleted by admin]
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #5 on: November 23, 2014, 12:44:57 PM »
Thanks Hayo,

I wil look into it...:-)

I found out in the meantime that if i use the old version Photo Mechanic Version 5.0, build 13915 (a16ea99) to ingest My RAW files and afterwards look in my Foto Folder there are no Side Car XMP files added..!! When ever i use the latest Build of Photo Mechanic Version 5.0, build 16101 (2631961) than the Side Car XMP files are Added to my Foto Folder.

I used the settings you mentioned...so to me there must be a bug some where in the latest version build.

The only work around is to Drag my RAW files in the open Contact Sheet directly (not using ingest) in Photo Mechanic Version 5.0, build 16101 (2631961) thats the only way to do it....So far.
« Last Edit: November 23, 2014, 01:23:48 PM by coljohnny »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20358
    • View Profile
    • Camera Bits, Inc.
Re: How to Block XMP files when using Ingest...!!
« Reply #6 on: November 23, 2014, 09:50:07 PM »
Please post a JPEG screen shot of your IPTC/XMP preferences.

Thanks,

-Kirk

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #7 on: November 23, 2014, 11:09:22 PM »
Please post a JPEG screen shot of your IPTC/XMP preferences.

Thanks,

-Kirk
Hello Kirk,

Screen shot from the settings IPTC/XMP preferences.

[attachment deleted by admin]

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2465
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #8 on: November 23, 2014, 11:42:01 PM »
For me this has worked with all versions of pm, old and new. So I still think there must be something else at play here. Have you touched those other files with other software too perhaps?

As a test I suggest you take a test shot and ingest it with pm. With the preference you set, there should be no XMP.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #9 on: November 23, 2014, 11:59:49 PM »
For me this has worked with all versions of pm, old and new. So I still think there must be something else at play here. Have you touched those other files with other software too perhaps?

As a test I suggest you take a test shot and ingest it with pm. With the preference you set, there should be no XMP.
Thanks Hayo,

I already Did and i din't touch the RAW files with any other programs and it still shows up those Side car XMP files.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2465
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #10 on: November 24, 2014, 01:05:02 AM »
This is really strange as it certainly works for me and afaik also for everyone else too. Have you tried this with a newly taken shot on a freshly formatted (in camera) card, and are you certain it is with the preferences as you showed?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #11 on: November 24, 2014, 01:31:24 AM »
This is really strange as it certainly works for me and afaik also for everyone else too. Have you tried this with a newly taken shot on a freshly formatted (in camera) card, and are you certain it is with the preferences as you showed?
Yes Hayo,

All the Above you mention I did it only happens in the latest build of Photo Mechanic.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2465
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #12 on: November 24, 2014, 01:52:09 AM »
Ah, weird! I now notice you mentioned you were on the 16101 release. Where did you get that from? The current official release is still at 15800…
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #13 on: November 24, 2014, 04:41:04 AM »
Ah, weird! I now notice you mentioned you were on the 16101 release. Where did you get that from? The current official release is still at 15800…

Camera Bits Send this to me for Download due to Other issues I mentioned in the fore last build..!!

This is what happens when I use ingest see screen shots.

[attachment deleted by admin]
« Last Edit: November 24, 2014, 04:58:31 AM by coljohnny »

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2465
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #14 on: November 24, 2014, 05:08:14 AM »
Right,

Seems like your problem unique to your specific PM version. The good news is that really seems isolated to your 16101 version (a newer beta version I'm working with, ingests fine without xmp files, not that I have your camera, but I don't think that should be it).

I expect a new release of PM soon and hopefully that will indeed solve your issue.

Cheers,
Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl