Author Topic: How to Block XMP files when using Ingest...!!  (Read 11677 times)

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #15 on: November 24, 2014, 05:16:04 AM »
Right,

Seems like your problem unique to your specific PM version. The good news is that really seems isolated to your 16101 version (a newer beta version I'm working with, ingests fine without xmp files, not that I have your camera, but I don't think that should be it).

I expect a new release of PM soon and hopefully that will indeed solve your issue.

Cheers,
Hayo

Thanks Hayo,

I'am sure Hayo its not a camera issue it only happens with Photo Mechanic Version 5.0, build 16101 (2631961).

Hope for the best I really like Photo Mechanic .

Regards Johnny

Offline dennis

  • President
  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 395
    • View Profile
    • Camera Bits, Inc.
Re: How to Block XMP files when using Ingest...!!
« Reply #16 on: November 24, 2014, 03:40:22 PM »
Hey Johnny,

A couple of issues:

The X3F format is not a TIFF-based format and therefore PM doesn't have a safe way to embed XMP (or anything else for that matter) inside of the RAW file.  So your only choice is to use a sidecar file, period.  Just because your PM prefs have "Always create and/or update XMP sidecar file" turned OFF does NOT mean an XMP sidecar won't be created.  It just means that PM will "not ALWAYS create an XMP sidecar file" (but will if necessary).  Please note this is for TIFF-based RAW formats only (and the setting therefore doesn't even apply to X3F).  If you want to add any metadata whatsoever to your RAW files using PM (or shall I say most other software including Adobe's software) then you will need to put this metadata into an XMP sidecar.  Adobe for example doesn't modify RAW files at all (that I am aware of) and ALL edits therefore must go into the XMP sidecar because there is no other place (that is standard) to store this information.  So for example if you "lock" your photos in the camera (to "tag" them) and you expect PM to mark these files as "tagged" upon ingest, then PM must put this "tag" flag into an XMP sidecar file due to the X3F format.  Even if you don't tag files, PM likes to "infer" the frame number upon ingest (as some cameras don't bother to include any kind of actuation count).

Also, if we give you a non-release version of PM for testing then please don't bother to publish any bugs about a non-release version publicly as we will not be able or bother to go back to an interim build to test anything.

HTH...

--dennis
« Last Edit: November 24, 2014, 04:40:42 PM by dennis »

Offline dennis

  • President
  • Camera Bits Staff
  • Sr. Member
  • *****
  • Posts: 395
    • View Profile
    • Camera Bits, Inc.
Re: How to Block XMP files when using Ingest...!!
« Reply #17 on: November 24, 2014, 03:44:18 PM »
Hayo,

BTW - I am surprised you are embedding XMP and IPTC into your NEF files now that you have moved to Adobe workflow.  I would recommend that you always force an XMP sidecar and NOT modify your RAW files as this is the safest way to handle RAW files and is what Adobe expects.  And since Adobe won't update any embedded XMP that may already exist, you could be reading stale data.  Best solution is to not modify RAW files, always force XMP, and read XMP sidecar first (if present), then embedded XMP, then IPTC as last resort.

Regards,

--dennis

Offline coljohnny

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: How to Block XMP files when using Ingest...!!
« Reply #18 on: November 24, 2014, 10:43:21 PM »
Hey Johnny,

A couple of issues:

The X3F format is not a TIFF-based format and therefore PM doesn't have a safe way to embed XMP (or anything else for that matter) inside of the RAW file.  So your only choice is to use a sidecar file, period.  Just because your PM prefs have "Always create and/or update XMP sidecar file" turned OFF does NOT mean an XMP sidecar won't be created.  It just means that PM will "not ALWAYS create an XMP sidecar file" (but will if necessary).  Please note this is for TIFF-based RAW formats only (and the setting therefore doesn't even apply to X3F).  If you want to add any metadata whatsoever to your RAW files using PM (or shall I say most other software including Adobe's software) then you will need to put this metadata into an XMP sidecar.  Adobe for example doesn't modify RAW files at all (that I am aware of) and ALL edits therefore must go into the XMP sidecar because there is no other place (that is standard) to store this information.  So for example if you "lock" your photos in the camera (to "tag" them) and you expect PM to mark these files as "tagged" upon ingest, then PM must put this "tag" flag into an XMP sidecar file due to the X3F format.  Even if you don't tag files, PM likes to "infer" the frame number upon ingest (as some cameras don't bother to include any kind of actuation count).

Also, if we give you a non-release version of PM for testing then please don't bother to publish any bugs about a non-release version publicly as we will not be able or bother to go back to an interim build to test anything.

HTH...

--dennis

Hey Dennis.

My apologies for any misunderstanding towards Photo Mechanic I was assuming that i had to download the latest version see note,

(If you are seeing odd behavior in Photo Mechanic on Yosemite you may want to download the latest version:

/download/PhotoMechanic5R16101.dmg)

I was not realizing that this was a non-release version.

Further more when I convert an X3F file to TIF 16 bit to Final edit in Adobe CS6 with or with out an XMP file I don't see any difference however with XMP Side car File its only cluttering up my Foto folders.

Thats all..!!

Thanks for the help,

Most regards Johnny.

« Last Edit: November 25, 2014, 01:10:04 AM by coljohnny »

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2468
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #19 on: November 24, 2014, 11:00:06 PM »
BTW - I am surprised you are embedding XMP and IPTC into your NEF files now that you have moved to Adobe workflow.  I would recommend that you always force an XMP sidecar and NOT modify your RAW files as this is the safest way to handle RAW files and is what Adobe expects.  And since Adobe won't update any embedded XMP that may already exist, you could be reading stale data.  Best solution is to not modify RAW files, always force XMP, and read XMP sidecar first (if present), then embedded XMP, then IPTC as last resort.,

Hi Dennis, don't be surprised ;)
I still have lots of raw files that have been edited by NX2, these have embedded metadata and will need to be kept that way. Secondly, my adobe workflow is purely dng, so I will never get an XMP file for that either as adobe embeds the data there too. So my settings give me the best of both worlds. Plus, even had I created an XMP for a file from within an Adobe application, my settings also make sure pm reads those first (upon creation, Adobe does read the embedded metadata, they just don't update it for non dng raw files). So, my settings are actually what I would recommend for a mixed environment.

Cheers,
Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Luiz Muzzi

  • Hero Member
  • *****
  • Posts: 678
    • View Profile
    • Luiz Muzzi Photography
Re: How to Block XMP files when using Ingest...!!
« Reply #20 on: December 18, 2014, 04:02:45 PM »
Hi, Hayo
I have to do this as well. I currently use both Lightroom and Canon's DPP in my workflow and DPP does not recognize PM's star ratings if I don't choose "Allow raw files to be modified" and "Add embedded metadata".
Regards,

-Luiz Muzzi


[attachment deleted by admin]