Author Topic: Strange error after saving photos with PM5  (Read 1965 times)

Offline DizzyReed

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Strange error after saving photos with PM5
« on: January 27, 2015, 01:00:06 PM »
Hello there,

today I encountered a very strange error after saving and resizing photos with PM. Now, I do general edit in PS or LR and save them as JPEG (4000 px on the long edge, 300 dpi, max 4MB size) and if I need photos to be published on some website I also resize and save them with Photo Mechanic as it is the fastest (1000 px on the long edge, 96 dpi, max 0.2MB size). After the save I got photos very similar to those after a memory card failure.
I also did a test save with saving NEF files directly into the JPEGs and the JPEGs came out with the same errors.

Has anyone else encountered this problem?

I am running Photo Mechanic Version 5.0, build 16231 (674b396) on Mac OS X 10.10.1 (MacPro Retina 15, late 2013)

[attachment deleted by admin]

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21663
    • View Profile
    • Camera Bits, Inc.
Re: Strange error after saving photos with PM5
« Reply #1 on: January 27, 2015, 01:23:37 PM »
Hello there,

today I encountered a very strange error after saving and resizing photos with PM. Now, I do general edit in PS or LR and save them as JPEG (4000 px on the long edge, 300 dpi, max 4MB size) and if I need photos to be published on some website I also resize and save them with Photo Mechanic as it is the fastest (1000 px on the long edge, 96 dpi, max 0.2MB size). After the save I got photos very similar to those after a memory card failure.
I also did a test save with saving NEF files directly into the JPEGs and the JPEGs came out with the same errors.

Has anyone else encountered this problem?

I am running Photo Mechanic Version 5.0, build 16231 (674b396) on Mac OS X 10.10.1 (MacPro Retina 15, late 2013)

No, because virtually no others have the build that you do that has that problem in it.  Please use this build instead: http://www.camerabits.com/download/PhotoMechanic5R16259.dmg

Thanks,

-Kirk

Offline DizzyReed

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Strange error after saving photos with PM5
« Reply #2 on: January 28, 2015, 03:10:28 AM »
Ok, thanks Kirk.

If it helps - I did a bit of "testing" yesterday and noticed that the problem occurs if I use the "Limit file size to: X.XX MB" option, but if I chose the "Quality Slider" everything was fine, the photos came out as they should.

Also, if I used the "Quality Slider" photos were saved/exported much quicker then with the "Limit size".

EDIT: I just installed and tested - the build you attached in the post works fine
« Last Edit: January 28, 2015, 03:26:55 AM by DizzyReed »

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21663
    • View Profile
    • Camera Bits, Inc.
Re: Strange error after saving photos with PM5
« Reply #3 on: January 28, 2015, 05:52:47 AM »
Also, if I used the "Quality Slider" photos were saved/exported much quicker then with the "Limit size".

This will always be true.  The Limit size option must compress each image several times in order to find the highest quality setting that produces a file size no larger than your limit size.  When the size limit feature is not used, the image is only compressed once, thus it is quicker.

-Kirk