Author Topic: Files Become "Hidden" When Copied  (Read 4670 times)

Offline H. Rose

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Files Become "Hidden" When Copied
« on: February 01, 2007, 10:05:02 AM »
I have been using Photo Mechanic for about two years.  I am using version 4.4.3.3. In the last few months I am getting a new, unwanted behavior:

When I "file->copy photos" in PM, the copied files become "Hidden".  So, PM does not see the new files.  At first it looks like PM deleted the files.  But the files are still there, just cannot be seen.  So then, I need to go into the Windows Explorer and set the properties of the files to no longer be hidden.  Then, PM can see the files and I can continue my work.

This does not occur when I "file->save photos as"; only when I "file->copy photos".

How can I get PM to stop making copied files hidden?

Thanks,
Heather

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Files Become "Hidden" When Copied
« Reply #1 on: February 01, 2007, 12:24:55 PM »
Heather,

I have been using Photo Mechanic for about two years.  I am using version 4.4.3.3. In the last few months I am getting a new, unwanted behavior:

When I "file->copy photos" in PM, the copied files become "Hidden".  So, PM does not see the new files.  At first it looks like PM deleted the files.  But the files are still there, just cannot be seen.  So then, I need to go into the Windows Explorer and set the properties of the files to no longer be hidden.  Then, PM can see the files and I can continue my work.

This does not occur when I "file->save photos as"; only when I "file->copy photos".

How can I get PM to stop making copied files hidden?

I just tried to reproduce it with my current development version and I cannot get it to happen.  The files are not hidden.

I'll try and reproduce it with the same version you are running and let you know what I find out.

-Kirk

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Files Become "Hidden" When Copied
« Reply #2 on: February 01, 2007, 01:04:54 PM »
Heather,

I have been using Photo Mechanic for about two years.  I am using version 4.4.3.3. In the last few months I am getting a new, unwanted behavior:

When I "file->copy photos" in PM, the copied files become "Hidden".  So, PM does not see the new files.  At first it looks like PM deleted the files.  But the files are still there, just cannot be seen.  So then, I need to go into the Windows Explorer and set the properties of the files to no longer be hidden.  Then, PM can see the files and I can continue my work.

This does not occur when I "file->save photos as"; only when I "file->copy photos".

How can I get PM to stop making copied files hidden?

I just tried to reproduce it with my current development version and I cannot get it to happen.  The files are not hidden.

I'll try and reproduce it with the same version you are running and let you know what I find out.

We tried to reproduce the problem on version 4.4.3.3 and could not get it to happen for us.  Can you tell us any more details, things like the source files are on one disk and the destination is on a different disk...

Any further information you can provide like all of the settings in the Copy Options dialog would be useful.

-Kirk

Offline H. Rose

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Files Become "Hidden" When Copied
« Reply #3 on: February 03, 2007, 11:50:27 PM »
Here's what I do:

- Ingest photos from Flash with PM onto NAS
- Tag photos in PM
- Copy with Move option set the tagged photos to a different directory on the NAS

Note: computer I am using is connected via Ethernet to the NAS where I store photos.

Photos that were copy/moved now no longer visible in PM.
Drop into Windows, turn off photos attribute "Hidden" (note "Archive" is also set)
Now photos are visible in PM.

What is strange is that I have been doing this same thing for over two years and then this "Hidden" irritation has only shown up in the last few months.

I am using:

PM 4.4.3.3
Windows  XP Pro 5.1.2600
Adaptec Snap Network Attached Storage (NAS) device
If it matters...I am using a Cisco Catalyst 5 switch for ethernet

Thanks for any help you can provide.

Regards,
Heather

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Files Become "Hidden" When Copied
« Reply #4 on: February 04, 2007, 12:14:20 AM »
Heather,

Here's what I do:

- Ingest photos from Flash with PM onto NAS
- Tag photos in PM
- Copy with Move option set the tagged photos to a different directory on the NAS

Note: computer I am using is connected via Ethernet to the NAS where I store photos.

Photos that were copy/moved now no longer visible in PM.
Drop into Windows, turn off photos attribute "Hidden" (note "Archive" is also set)
Now photos are visible in PM.

What is strange is that I have been doing this same thing for over two years and then this "Hidden" irritation has only shown up in the last few months.

I am using:

PM 4.4.3.3
Windows  XP Pro 5.1.2600
Adaptec Snap Network Attached Storage (NAS) device
If it matters...I am using a Cisco Catalyst 5 switch for ethernet

Thanks for any help you can provide.

What happens if you ingest to your local hard drive and copy to your local hard drive (don't involve the NAS)?  (I don't mean to say that you should abandon your network drive, I just want to know what happens for comparative purposes.)

-Kirk

Offline H. Rose

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Files Become "Hidden" When Copied
« Reply #5 on: February 07, 2007, 09:50:55 PM »
Excellent question.  I just tried it on the local disk and the problem went away.

Regards,
Heather

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Files Become "Hidden" When Copied
« Reply #6 on: February 08, 2007, 06:48:35 AM »
Heather,

Excellent question.  I just tried it on the local disk and the problem went away.

Can you have an IT person check out the settings on the NAS, and specifically the permissions for your account?

HTH,

-Kirk

Offline H. Rose

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Files Become "Hidden" When Copied
« Reply #7 on: February 10, 2007, 09:36:15 AM »
Yes, thank you.  My IT person will "get right on it" as he says.

Regards,
Heather

Offline Kevin M. Cox

  • Sr. Member
  • ****
  • Posts: 417
  • PM 5 Build 19749 | macOS 10.13.6 (17G7024)
    • View Profile
    • Kevin M. Cox | Photojournalist
Re: Files Become "Hidden" When Copied
« Reply #8 on: February 10, 2007, 09:19:44 PM »
Hey guys, I had this happen tonight and it made me remember that I've also seen it in the past.

I had a contact sheet open, selected a single photo and using "Command Y" moved it (by checking the required box) to my desktop. However when I went looking for it later it was nowhere to be found. A spotlight search turned it up and reported it as being on the desktop. I was able to find and move it again by browsing to my desktop folder inside my home folder.

I'm just assuming this is a problem with the Finder not properly refreshing the contents of my desktop vs. a problem with PM.
Kevin M. Cox | Photojournalist
https://www.KevinCox.com