Author Topic: Auto-start ingestion  (Read 4662 times)

Offline Linwood

  • Newcomer
  • *
  • Posts: 47
    • View Profile
Auto-start ingestion
« on: April 08, 2016, 07:33:25 PM »
This is a very minor thing, but I am curious if I am missing some option.

I have the latest PM on Windows 10 x 64, with an XQD reader (Lexar XR2).

When I insert a card, it starts PM and opens the ingestion dialog.   Great.

When I finish I remove the card, and insert another one.  PM is already running.  Nothing happens. 

Shouldn't the ingest dialog pop up without having to be selected from the menu?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24800
    • View Profile
    • Camera Bits, Inc.
Re: Auto-start ingestion
« Reply #1 on: April 08, 2016, 07:47:01 PM »
It should.  How are you unmounting the card?  When you insert the new card, does the OS recognize it?

-Kirk

Offline Linwood

  • Newcomer
  • *
  • Posts: 47
    • View Profile
Re: Auto-start ingestion
« Reply #2 on: April 09, 2016, 09:35:06 AM »
It should.  How are you unmounting the card?  When you insert the new card, does the OS recognize it?

I let PM dismount it when it is done ingesting.

I'll do it and take notes as I go.

- PM not running, card not mounted.  Explorer does not show the drive.
- Put card in slot, all these things happen.
---- PM starts
---- Explorer shows "Nikon D5 (E:)" as new drive
---- Ingestion dialog starts
- I click Ingest (note that "Unmount source disk after ingest" but "Erase" is not
- Ingest runs, finds a file and loads it
- Contact sheet opens (as set) and Drive disappears from explorer

So I remove card, reformat, take a new photo (just to be sure everything is fresh):

- Insert card
- The icon for PM on the task bar flashes, but if I click on it nothing appears but the contact sheet that was already there.
- The OS recognizes it as the same drive as before (NIKON D5 (E:))
- If I manually run File, Ingest, the ingestion dialog opens and works as before, seeing it and reading it

It's just this manual step of File, Ingest that is needed, but curious why it is not invoked.  in fact, I think it is TRYING to invoke, because I see the task bar flash, it just never comes up.

It's 100% repeatable.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24800
    • View Profile
    • Camera Bits, Inc.
Re: Auto-start ingestion
« Reply #3 on: April 09, 2016, 01:14:17 PM »
It should.  How are you unmounting the card?  When you insert the new card, does the OS recognize it?

I let PM dismount it when it is done ingesting.

I'll do it and take notes as I go.

- PM not running, card not mounted.  Explorer does not show the drive.
- Put card in slot, all these things happen.
---- PM starts
---- Explorer shows "Nikon D5 (E:)" as new drive
---- Ingestion dialog starts
- I click Ingest (note that "Unmount source disk after ingest" but "Erase" is not
- Ingest runs, finds a file and loads it
- Contact sheet opens (as set) and Drive disappears from explorer

So I remove card, reformat, take a new photo (just to be sure everything is fresh):

- Insert card
- The icon for PM on the task bar flashes, but if I click on it nothing appears but the contact sheet that was already there.
- The OS recognizes it as the same drive as before (NIKON D5 (E:))
- If I manually run File, Ingest, the ingestion dialog opens and works as before, seeing it and reading it

It's just this manual step of File, Ingest that is needed, but curious why it is not invoked.  in fact, I think it is TRYING to invoke, because I see the task bar flash, it just never comes up.

It's 100% repeatable.

Thanks for the details.  Is PM in the foreground (front-most application) when you insert the card the second time?

-Kirk

Offline Linwood

  • Newcomer
  • *
  • Posts: 47
    • View Profile
Re: Auto-start ingestion
« Reply #4 on: April 09, 2016, 01:29:59 PM »

Thanks for the details.  Is PM in the foreground (front-most application) when you insert the card the second time?

It was not when I did it before (as I had clicked on Explorer).

But I just tried it again, being sure to leave PM in foreground, and it did the same thing.

I actually tried it two ways, because the first time the ingestion dialog closes itself (I.e. I wasn't sure that PM remained fully in foreground), so I tried it a second time actually clicking on PM first, inserting the card.  No sign of any activity in either case.  When it's in background the icon on the task bar flashes, but if you click it, there is no new dialog on PM.


Offline Linwood

  • Newcomer
  • *
  • Posts: 47
    • View Profile
Re: Auto-start ingestion
« Reply #5 on: April 14, 2016, 07:32:30 PM »
This acts the same way on build 17338 (not that I expected it to be fixed, just passing it on).