Author Topic: Select All in Structure Keywords issue  (Read 1272 times)

Offline JustinT

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Select All in Structure Keywords issue
« on: April 23, 2018, 01:38:00 PM »
Hey PM folks,

Is there any chance this bug (I believe it's a bug) could be addressed? It's led to some screwed up captions. Also to me misspelling my name.

When using Structured Keywords, "Command+A" for select all does not do that function. Instead it closes the SK window and leaves the cursor active in the last window it was selected — which for me is usually the caption window.

This issue happens because I’m usually trying to hit Select All to delete the keyword I inputted.

For example, I type in “performance” but I don’t like the structured keyword options I’m getting, I’ll want to delete what I wrote and start a new search, but stay in SK.

What actually ends up happening is that the Structured Keywords disappears, and while I’m clicking the delete button (with the intention of deleting the keyword I wrote), I delete text from somewhere in my caption. But because I wasn’t expecting this, and sometimes I don’t know where the cursor is, it’s hard to find out what text was deleted until it’s too late.

I would love it if Command+A could behave the same way in Structured keywords as everywhere else in PM. It will help me keep from accidentally chopping letters from my name, among other issues.

Have not found anything on this issue after a cursory search here, but, it could be an issue with my keywording…

Thanks!!!!

My system:

Photo Mechanic Version 5.0, build 19395 (69a3200)
Mac 10.13.1