Author Topic: Progress Bar Doesn't Show Enough Progress  (Read 3672 times)

Offline OldRadioGuy

  • Member
  • **
  • Posts: 99
  • Retired broadcast journalist/educator
    • View Profile
Progress Bar Doesn't Show Enough Progress
« on: April 23, 2019, 12:42:40 PM »
1. Select images in a folder
2. Right-Click & select Include Items in Catalog
3. Window opens, showing Progress Bar
4. Progress Bar shows only progress in increments of 100.

It's easy to mistakenly conclude there's no progress with this kind of reporting. The bar should report continuous progress with each image added to the catalog.
-------------
Olympus E-M1 Mark III, Olympus PEN-F

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24786
    • View Profile
    • Camera Bits, Inc.
Re: Progress Bar Doesn't Show Enough Progress
« Reply #1 on: April 23, 2019, 12:55:02 PM »
1. Select images in a folder
2. Right-Click & select Include Items in Catalog
3. Window opens, showing Progress Bar
4. Progress Bar shows only progress in increments of 100.

It's easy to mistakenly conclude there's no progress with this kind of reporting. The bar should report continuous progress with each image added to the catalog.

PM sends the images in batches of one hundred to the Catalog server (it's still a server even though it is running locally) and does not receive feedback until it's ready to send the next batch.  PM could send them one by one, but then it would take longer.

-Kirk

Offline OldRadioGuy

  • Member
  • **
  • Posts: 99
  • Retired broadcast journalist/educator
    • View Profile
Re: Progress Bar Doesn't Show Enough Progress
« Reply #2 on: April 23, 2019, 07:45:18 PM »
OK, that makes sense.
-------------
Olympus E-M1 Mark III, Olympus PEN-F