Author Topic: PM+ Catalog Disabled on startup after Build 5560 upgrade  (Read 1560 times)

Offline MarkWagner

  • Newcomer
  • *
  • Posts: 7
    • View Profile
PM+ Catalog Disabled on startup after Build 5560 upgrade
« on: March 05, 2021, 10:34:55 AM »
Please can you help ?

When I startup PM+ on my MacBookPro with OS10.10.6 Yosemite it says the catalog function is disabled - see screen shots attached. I’ve tried restarting etc to no avail. This does follow a PM+ upgrade last Monday to build 5560. But it did work ok at first after upgrade with catalog showing up. Suddenly 2 days ago it stared being disabled.

Please can you help ?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24799
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Catalog Disabled on startup after Build 5560 upgrade
« Reply #1 on: March 05, 2021, 10:52:19 AM »
I'd like to see your Photo Mechanic log.  In Photo Mechanic go to the Help menu and choose "Reveal Support Data..." and moments later a Finder window will come forward with the zipped log file selected.  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your zipped PM log file.

Thanks,

-Kirk

Offline MarkWagner

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PM+ Catalog Disabled on startup after Build 5560 upgrade
« Reply #2 on: March 06, 2021, 08:51:32 AM »
Hi Kirk.

Thanks for the swift follow up.
Attached is the PM_log zip file and I just clicked on my version of PM6 and it refused to open at all - I attach the message I got from that too in case the two are related.
Both were working fine previously.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24799
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Catalog Disabled on startup after Build 5560 upgrade
« Reply #3 on: March 06, 2021, 12:06:33 PM »
Thanks for the log file, Mark.

It's looking like something has gone awry with one of the database files.  Make sure Photo Mechanic Plus isn't running and then do the following:

In the Finder choose "Go to Folder..." on the Go menu.  Copy and paste the following into the "Go to the folder:" field:

~/Library/Application Support

And click the "Go" button.  Then open the "Camera Bits, Inc" folder followed by the "Photo Mechanic" folder.  Finally, open the "catalog" folder followed by the "state" folder.

There should be a "cat_state.sq3" file in the "state" folder.  Rename it by putting an 'x' at the start of its name.

Launch Photo Mechanic Plus.  It should now launch.

You will need to do a "Locate Existing Catalog..." on each of your catalogs, and once they're acquired you'll have to perform a "Reintegrate Forgotten Catalog..." maintenance operation on each of them.  You can do both of these tasks in the Catalog Management window.  (Catalog->Manage Catalogs...)

The Locate Existing Catalog... button is near the bottom of the "Local Catalogs" area.  Maintenance is done per-catalog, and to get to it, you click on the triangle to the left of each catalog name.  This will reveal some controls and another expandable area labeled "Maintenance".  Click on the triangle to expand Maintenance.  Then click on the "Reintegrate Forgotten Catalog" button.  Do this for each of your Catalog(s).

HTH,

-Kirk

Offline MarkWagner

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: PM+ Catalog Disabled on startup after Build 5560 upgrade
« Reply #4 on: March 06, 2021, 03:26:28 PM »
Kirk
Thank you very much indeed - all sorted