Author Topic: Spotlight search troubles w/ 4.5.3.2  (Read 5447 times)

Offline drjay32

  • Newcomer
  • *
  • Posts: 46
    • View Profile
    • Luminescence of Nature Photograpy
Spotlight search troubles w/ 4.5.3.2
« on: August 14, 2008, 05:55:26 AM »
I have noticed odd behavior using the Spotlight search on my Mac Pro, OS 10.5.4.

If I do a "Quick Search" on "D300", I get instant results.  However, if I use the advanced search and choose "Camera Model contains D300" my computer starts indexing my drive again and the search fails.

Any ideas?

-Jason
Jason P. Odell
Photographer and author in Colorado, USA
www.luminescentphoto.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24813
    • View Profile
    • Camera Bits, Inc.
Re: Spotlight search troubles w/ 4.5.3.2
« Reply #1 on: August 14, 2008, 06:47:13 AM »
Jason,

I have noticed odd behavior using the Spotlight search on my Mac Pro, OS 10.5.4.

If I do a "Quick Search" on "D300", I get instant results.  However, if I use the advanced search and choose "Camera Model contains D300" my computer starts indexing my drive again and the search fails.

No ideas off-hand.  What happens if you do a similar search with Spotlight directly?

-Kirk


Offline drjay32

  • Newcomer
  • *
  • Posts: 46
    • View Profile
    • Luminescence of Nature Photograpy
Re: Spotlight search troubles w/ 4.5.3.2
« Reply #2 on: August 14, 2008, 05:41:56 PM »
Kirk-
Spotlight pulls up my image files when I type in D300.
Any time I'm using the advanced Spotlight search in PM, I'm not getting anywhere-- the spotlight icon indicates that the drive is being indexed.

-Jason

Jason P. Odell
Photographer and author in Colorado, USA
www.luminescentphoto.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24813
    • View Profile
    • Camera Bits, Inc.
Re: Spotlight search troubles w/ 4.5.3.2
« Reply #3 on: August 14, 2008, 06:50:33 PM »
Jason,

Spotlight pulls up my image files when I type in D300.
Any time I'm using the advanced Spotlight search in PM, I'm not getting anywhere-- the spotlight icon indicates that the drive is being indexed.

If you're using the Spotlight menu then you're using basically the same mechanism as the Quick Search.  You would need to do an advanced search with Spotlight in order to imitate what the Search panel in Photo Mechanic does.

Use Find on the File menu in the Finder and add the same criteria.  Let me know if you get the same issue.  If so, we may have to open up an issue with Apple.

Thanks,

-Kirk

Offline drjay32

  • Newcomer
  • *
  • Posts: 46
    • View Profile
    • Luminescence of Nature Photograpy
Re: Spotlight search troubles w/ 4.5.3.2
« Reply #4 on: August 15, 2008, 07:02:46 PM »
Kirk-
When I choose "Device Model" contains "D300" in the advanced find, I get tons of hits.

-Jason
Jason P. Odell
Photographer and author in Colorado, USA
www.luminescentphoto.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24813
    • View Profile
    • Camera Bits, Inc.
Re: Spotlight search troubles w/ 4.5.3.2
« Reply #5 on: August 15, 2008, 11:51:37 PM »
Jason,

When I choose "Device Model" contains "D300" in the advanced find, I get tons of hits.

Can you save your query from Spotlight and send me the file?

Thanks,

-Kirk

« Last Edit: August 15, 2008, 11:53:16 PM by Kirk Baker »