Author Topic: Problem with E key (edit in external editor)  (Read 4026 times)

Offline vish

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Problem with E key (edit in external editor)
« on: March 24, 2009, 05:16:44 AM »
OS X 10.5.6, PM 4.6, RAM 4 GB

I’m having problems with launching file in external editor via E key when in Preview window. If I right-click on an image and select Edit photo, that’ll open file in external editor as it should, but I’m unable to do the same with the E key and the Edit button in a toolbar is greyed out.

This was working fine on OS X before 4.6 release and its working fine on Windows in 4.6.

Could it be that I have misconfigured something in PM’s preferences for this to work?

thanks


[attachment deleted by admin]

Offline platti

  • Full Member
  • ***
  • Posts: 187
    • View Profile
    • my gallery on zenfolio
Re: Problem with E key (edit in external editor)
« Reply #1 on: March 24, 2009, 06:16:54 AM »
Hi,
it's working fine in 4.6.1 beta ... :)
greets from a hill
my gallery on zenfolio

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24786
    • View Profile
    • Camera Bits, Inc.
Re: Problem with E key (edit in external editor)
« Reply #2 on: March 24, 2009, 06:17:51 AM »
OS X 10.5.6, PM 4.6, RAM 4 GB

I’m having problems with launching file in external editor via E key when in Preview window. If I right-click on an image and select Edit photo, that’ll open file in external editor as it should, but I’m unable to do the same with the E key and the Edit button in a toolbar is greyed out.

This was working fine on OS X before 4.6 release and its working fine on Windows in 4.6.

Could it be that I have misconfigured something in PM’s preferences for this to work?

Check the Launching tab of the Preferences dialog.  Check to see if you have any editors defined.

-Kirk

Offline vish

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with E key (edit in external editor)
« Reply #3 on: March 24, 2009, 06:26:21 AM »
Hi Kirk,

In preferences I manually defined editors for a specific formats.
When I try to launch with E key external editor from Preview window it doesn't react in any way, but if i press Escape key returning to the contact sheet view with the same file selected and press E key, this will launch external editor as expected.


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24786
    • View Profile
    • Camera Bits, Inc.
Re: Problem with E key (edit in external editor)
« Reply #4 on: March 24, 2009, 08:23:11 AM »
In preferences I manually defined editors for a specific formats.
When I try to launch with E key external editor from Preview window it doesn't react in any way, but if i press Escape key returning to the contact sheet view with the same file selected and press E key, this will launch external editor as expected.

Try setting a default editor as well.

That should re-enable the toolbar item.  Your specific editors should still be used.

-Kirk

Offline vish

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: Problem with E key (edit in external editor)
« Reply #5 on: March 24, 2009, 01:30:31 PM »
Thanks Kirk

That fixed it.