Author Topic: PM Crashes when Searching Using 'Find' and 'Find/Replace'  (Read 2174 times)

Offline Jerry

  • Newcomer
  • *
  • Posts: 5
    • View Profile
PM Crashes when Searching Using 'Find' and 'Find/Replace'
« on: March 16, 2010, 08:33:22 AM »
I am running Photo Mechanic version 4.6.3 and I run Win 7 64-bit on my Lenovo laptop.  I am trying to replace a hierarchical keyword separator ';' with '|' and everytime a run the 'Find' or 'Find'Replace' PM crashes; the dialog window header indicates 'not responding'.  The folder that I'm searching has about 20,000 images in it.  Is the folder too large?

Thanks in advance for your help.

Jerry


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24801
    • View Profile
    • Camera Bits, Inc.
Re: PM Crashes when Searching Using 'Find' and 'Find/Replace'
« Reply #1 on: March 16, 2010, 08:37:04 AM »
Jerry,

I am running Photo Mechanic version 4.6.3 and I run Win 7 64-bit on my Lenovo laptop.  I am trying to replace a hierarchical keyword separator ';' with '|' and everytime a run the 'Find' or 'Find'Replace' PM crashes; the dialog window header indicates 'not responding'.  The folder that I'm searching has about 20,000 images in it.  Is the folder too large?

20,000 is a lot of files.  Until all of the metadata for the 20,000 files is loaded, the Find/Replace will take a long time to complete.  Perhaps more than 10 minutes.  It hasn't crashed.  It's just busy doing the search.  Just let it complete, or select a smaller number of files and do them in batches.

-Kirk

Offline Jerry

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: PM Crashes when Searching Using 'Find' and 'Find/Replace'
« Reply #2 on: March 16, 2010, 02:43:32 PM »
Hi Kirk,

Thank you for your quick reply.  Yes, patience was the answer.  Didn't realize how much of an effort is required; think I'll also try smaller batches to avoid the long stretches.

Jerry