Author Topic: Is it me or is Find And Replace not working in build 15451?  (Read 12727 times)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: Is it me or is Find And Replace not working in build 15451?
« Reply #15 on: August 10, 2016, 09:01:43 PM »

They are just the two noted above. I'm not even sure that these changes contain the culprit, only that I changed them as shown, and the tool worked--very mysterious. I just hope that this might trigger some wisdom on the code entailed that might contain the issue.

If an image has metadata of both types (legacy IPTC and modern XMP) and the data in them is not identical then the order of reading that data can change the results.  PM will always keep both types of metadata in sync when it updates the metadata for an image.  But not all apps do this.  So if you chose to read IPTC before XMP and the word you're searching for is only found in the XMP then PM's find features won't find the word.  Inverse the settings and PM will find your word.  PM does not merge differing values together to form a union for each metadata field.

In looking at the metadata in your sample image, I see the word "Lyons" in both types of metadata.  In the legacy IPTC metadata, the words "Port Lyons" exists in the Keywords and in the Sub-location fields.  In the modern XMP metadata the words "Port Lyons" appear in the Sub-location and Keywords fields.  So I expect it to not matter which order the metadata types (IPTC or XMP) are loaded.

Now, if you're not testing with this exact photo (the one you supplied) and are using a different image for your tests or you're in RAW+JPEG and you've told PM to use the metadata associated with the RAW file then I'd need to have access to the RAW file as well and any XMP sidecar file it may have.

Would you mind reversing your settings until the problem begins to happen again and then screenshot the various settings that you think may have bearing on this issue?



Offline gdpaige

  • Newcomer
  • *
  • Posts: 31
    • View Profile
Re: Is it me or is Find And Replace not working in build 15451?
« Reply #16 on: August 11, 2016, 05:33:24 AM »
Kirk:  I'll do the tests tonight after work. I should note that the Find tool worked without flaw all along, it is only the replace aspect that failed. Also, I made the jpg from the NEF in PM, and the same behavior applied to both files independently. If one file failed, so did the other, and once it worked, it worked on both. Perhaps these new tidbits help?