Author Topic: Copyright and Creator not filtering  (Read 412 times)

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Copyright and Creator not filtering
« on: September 06, 2019, 10:35:46 PM »
Windows 10 with very latest build with new filter behaviour.

I have many photos with Copyright and Creator IPTC fields populated.  I select filters with these IPTC filds but they do not filter at all.  EXIF User does show though.  Best described with a screenshot.


Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #1 on: September 06, 2019, 10:37:30 PM »
Sorry about the huge screenshot but comes from a 4k screen.  Please view the whole screenshot so see all info required to make sense of this issue.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: Copyright and Creator not filtering
« Reply #2 on: September 06, 2019, 10:41:02 PM »
I'm not sure what the problem is?  Your Metadata Info dialog isn't showing the Copyright field so I can't tell if the gecko image has text in the copyright field.  If it does have data and it isn't showing up in the filter as an individual item then something is wrong.

-Kirk

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #3 on: September 06, 2019, 11:02:10 PM »
Sorry, must have moved before taking the screenshot.  New screenshot attached.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: Copyright and Creator not filtering
« Reply #4 on: September 06, 2019, 11:03:36 PM »
Do you only have one catalog?  Did you re-index your catalog(s) with the new beta?  (The one released on August 30th.)

-Kirk

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #5 on: September 07, 2019, 06:47:05 PM »
I only have one catalog and did re-index as requested with the August 30th build.  I thought I would re-index just to be safe and no change.  Next I deleted the catalog and created a new one and added a small set of photos to it but still no joy!

There was one bug I found while re-indexing: my setting for Search and Add/Modify were cleared so my initial filter was empty.  Please remember these settings when performing maintenance as it really confused me initially.


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: Copyright and Creator not filtering
« Reply #6 on: September 07, 2019, 07:13:54 PM »
I only have one catalog and did re-index as requested with the August 30th build.  I thought I would re-index just to be safe and no change.  Next I deleted the catalog and created a new one and added a small set of photos to it but still no joy!

There was one bug I found while re-indexing: my setting for Search and Add/Modify were cleared so my initial filter was empty.  Please remember these settings when performing maintenance as it really confused me initially.

Yes, I found that confusing as well.  We have to take the catalog off line while the indexing is happening, but when you only have one catalog, it should probably be restored on completion or user-confusion will occur.

Were those filter fields IPTC or EXIF?

-Kirk

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #7 on: September 08, 2019, 04:24:50 AM »
The search fields were IPTC fields.  The User field which works fine was EXIF.

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #8 on: September 12, 2019, 06:08:54 PM »
Done some more testing in the latest build 3677.

1. Using exiftool I searched for the string 'Vlasta' which appears in the Copyright field and it returned Result 1
2. Browse result shown in Browse 1
3. I thought that maybe the '-' was affecting the result so I changed the text in the Creator/Photographer field to remove the '-'
4. Browse now shown in Browse 2
5. exiftool result shown in Result 2

The IPTC Metadata screenshot after the removal of '-' shows the only fields that contain the name Vlasta.

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #9 on: September 12, 2019, 06:16:18 PM »
Just re-indexed the catalog and the scenario where I removed the '-' is no longer valid - the result is the same as for with the '-' in the text.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2433
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Copyright and Creator not filtering
« Reply #10 on: September 13, 2019, 01:08:31 AM »
Keith, I'm not sure I see what the problem is; browse 1 and browse 2 seemed OK to me. Or are the not 11 (10 for browse 2 since you renamed) images with "Vlasta Ross-Jones" as byline?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline kclaar

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: Copyright and Creator not filtering
« Reply #11 on: September 13, 2019, 11:54:47 AM »
Keith,

Sort of taking a stab here... I see you've filled out the info in the Image Rights section, which includes a copyright. But I believe the filter dropdown copyright is referencing the Models, Properties and Artwork section, which also has copyright information.

In my own catalog, my results are the same as yours. If I use the search option, and search on copyright = Kenneth W. Claar, I do get my copyright results. The copyright field in the Image Rights section is not indexed, but can be searched (see the Searchable Fields dialog).

My copyright field is patterned copyright symbol yyyy, Kenneth W. Claar, and the above search works, even though I omitted the symbol and the year in the search string.

This may not help you, but may explain the results you're getting.

-- Ken Claar

Offline kclaar

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Re: Copyright and Creator not filtering
« Reply #12 on: September 14, 2019, 08:17:06 AM »
Keith,

I'd like to amend some of the above....

If you do a search on the field artobj.copyright, I think you'll find your copyright information. Both this field and the general copyright fields are indexed, which is why you can search on them (I was wrong above).

-- Ken

Offline KeithRJ

  • Newcomer
  • *
  • Posts: 33
    • View Profile
Re: Copyright and Creator not filtering
« Reply #13 on: Yesterday at 05:46:02 AM »
Ken,

been away for a few days hence my silence.

The Copyright and Creator fields are filled in by my camera (Canon 70D and 77D) so I have NOT made any changes to IPTC data at all besides removing the '-' to see if that made any difference.

The Copyright/Photographer and Copyright fields under Image Rights shown when clicking the 'i' on the thumbnail show perfectly.  I would expect this to show in the IPTC section in Browse too.  See my earlier screenshots.

If it would help I can post an image for you to test.

Maybe you need to add an Image Rights section in Browse under IPTC.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2433
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Copyright and Creator not filtering
« Reply #14 on: Yesterday at 06:32:17 AM »
Ah, now i see what you mean: in the browser, the copyright is only shown as none even though you clearly have something filled in. That’s indeed wrong. It seems this is an omission in PM's indexing; while I too have the copyright field filled, I don't see any data for it either.
Hayo Baan - Photography
Web: www.hayobaan.nl