Author Topic: Color class disappears when file edited and thumbnail updated  (Read 5216 times)

Offline charlesteton

  • Member
  • **
  • Posts: 89
    • View Profile
    • www.charlesteton.com
Color class disappears when file edited and thumbnail updated... Editing final files with Photoshop, when saved and look back in browser view in Photo Mechanic, my color class has disappeared. Happens with jpg and psd files.

Many thanks.
Charles Teton
www.makingmymovie.com

Support Info: PM 5 latest, 2 x Canon EOS 1D MK IV, 2 x 15" MacBook Pro 2.4GHz, 4GB DDR2, Mac OS 10.6.8, 20" Apple Cinema Display. Multiple Firewire 400 & 800 HD's and Multiple USB 2.0 HD's, approx. 12TB total.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Color class disappears when file edited and thumbnail updated
« Reply #1 on: July 25, 2006, 08:43:45 AM »
Charles,

Color class disappears when file edited and thumbnail updated... Editing final files with Photoshop, when saved and look back in browser view in Photo Mechanic, my color class has disappeared. Happens with jpg and psd files.

Do you have the setting "Save/load tag and color class in IPTC/XMP:" set to "For all photos"?  (It's on the Files tab of the Preferences dialog.)  If this is not set to "For all photos" then what you describe is expected behavior.

HTH,

-Kirk

Offline charlesteton

  • Member
  • **
  • Posts: 89
    • View Profile
    • www.charlesteton.com
Re: Color class disappears when file edited and thumbnail updated
« Reply #2 on: July 25, 2006, 08:53:17 AM »
Thanks, it was set to Never... Will it cause any other behaviour?
Charles Teton
www.makingmymovie.com

Support Info: PM 5 latest, 2 x Canon EOS 1D MK IV, 2 x 15" MacBook Pro 2.4GHz, 4GB DDR2, Mac OS 10.6.8, 20" Apple Cinema Display. Multiple Firewire 400 & 800 HD's and Multiple USB 2.0 HD's, approx. 12TB total.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Color class disappears when file edited and thumbnail updated
« Reply #3 on: July 25, 2006, 09:17:05 AM »
Charles,

Thanks, it was set to Never... Will it cause any other behaviour?

The way it works is that Photo Mechanic writes your edits (tag, color class, rating, etc.) into an unused IPTC field.  So when you have this feature turned on and you tag or color class a photo, an IPTC record is added to the photo with the edits contained within.

Effective and shouldn't cause a problem.  Any editor that preserves IPTC or XMP information when saving a file will preserve your edits.  Photoshop definitely works this way.

-Kirk

Offline charlesteton

  • Member
  • **
  • Posts: 89
    • View Profile
    • www.charlesteton.com
Re: Color class disappears when file edited and thumbnail updated
« Reply #4 on: July 25, 2006, 09:41:57 AM »
Thanks great... Off on holiday soon... Try and get one yourself...
Charles Teton
www.makingmymovie.com

Support Info: PM 5 latest, 2 x Canon EOS 1D MK IV, 2 x 15" MacBook Pro 2.4GHz, 4GB DDR2, Mac OS 10.6.8, 20" Apple Cinema Display. Multiple Firewire 400 & 800 HD's and Multiple USB 2.0 HD's, approx. 12TB total.

Offline nancyr

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color class disappears when file edited and thumbnail updated
« Reply #5 on: August 01, 2006, 08:30:17 AM »
Can't get it to work with NEFs in Nikon Capture (4.4.1). Actually, it just now worked on one file, followed by 3 that lost their label. Can't discern a pattern; good file was a horizontal from D200. Others were vertical (D200), horizontal (D200), and horizontal (D70). Reasonably similar changes to each.

Any thoughts, or is it just another way Capture is retarded? (Not yet an NX fan.) Thanks.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Color class disappears when file edited and thumbnail updated
« Reply #6 on: August 01, 2006, 08:38:57 AM »
Can't get it to work with NEFs in Nikon Capture (4.4.1). Actually, it just now worked on one file, followed by 3 that lost their label. Can't discern a pattern; good file was a horizontal from D200. Others were vertical (D200), horizontal (D200), and horizontal (D70). Reasonably similar changes to each.

Any thoughts, or is it just another way Capture is retarded? (Not yet an NX fan.) Thanks.

Do you have the setting "Save/load tag and color class in IPTC/XMP:" set to "For all photos"?  (It's on the Files tab of the Preferences dialog.)  If this is not set to "For all photos" then what you describe is somewhat expected behavior.

But here is something you could try.  Caption several images.  Run them through Capture.  Look at them back in Photo Mechanic.  Check their captions.  Are they still there, or have they been stripped?  If they're still there then as long as you have the above-described setting set to "For all photos" then your tags and Color Classes should survive.

HTH,

-Kirk

Offline nancyr

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: Color class disappears when file edited and thumbnail updated
« Reply #7 on: August 01, 2006, 09:09:29 AM »
Do you have the setting "Save/load tag and color class in IPTC/XMP:" set to "For all photos"?  (It's on the Files tab of the Preferences dialog.)  If this is not set to "For all photos" then what you describe is somewhat expected behavior.

But here is something you could try.  Caption several images.  Run them through Capture.  Look at them back in Photo Mechanic.  Check their captions.  Are they still there, or have they been stripped?  If they're still there then as long as you have the above-described setting set to "For all photos" then your tags and Color Classes should survive.

Wow, you're quick!

Yes, Save/load tag is "for all photos," and they're holding their IPTC info, and now all are working as expected. I swear this didn't work half an hour ago, and I didn't change a single setting in either app! Guess I just needed to ask. It's like that one person in the office who can stand next to the xerox machine and it doesn't jam... Thanks again.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Color class disappears when file edited and thumbnail updated
« Reply #8 on: August 01, 2006, 09:27:03 AM »
Do you have the setting "Save/load tag and color class in IPTC/XMP:" set to "For all photos"?  (It's on the Files tab of the Preferences dialog.)  If this is not set to "For all photos" then what you describe is somewhat expected behavior.

But here is something you could try.  Caption several images.  Run them through Capture.  Look at them back in Photo Mechanic.  Check their captions.  Are they still there, or have they been stripped?  If they're still there then as long as you have the above-described setting set to "For all photos" then your tags and Color Classes should survive.

Wow, you're quick!

Usually, yes I am.

Quote from: nancyr
Yes, Save/load tag is "for all photos," and they're holding their IPTC info, and now all are working as expected. I swear this didn't work half an hour ago, and I didn't change a single setting in either app! Guess I just needed to ask. It's like that one person in the office who can stand next to the xerox machine and it doesn't jam... Thanks again.

I know it is working for plenty of folks (especially those that hounded me to get that feature implemented ;) ) so I knew it should be working for you too.

-Kirk