Author Topic: PM 4.6.5...Send photo via email.....  (Read 2781 times)

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
PM 4.6.5...Send photo via email.....
« on: September 19, 2010, 08:57:49 AM »
I know that this issue has been touched on before by various users. Has any fix/work-a-round been found as yet.

It seems to be an issue only for Windows7 users and does seem to be an issue with PM rather than Windows/Outlook.
Basically PM seems to be populating the 'Email type' field in outlook with the recipient email address, replacing the required 'SMTP'.

Any ideas?

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #1 on: September 19, 2010, 09:08:18 AM »
I notice this issue is not fixed in the Beta 4.6.6  :'(

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: PM 4.6.5...Send photo via email.....
« Reply #2 on: September 19, 2010, 06:06:47 PM »
I know that this issue has been touched on before by various users. Has any fix/work-a-round been found as yet.

It seems to be an issue only for Windows7 users and does seem to be an issue with PM rather than Windows/Outlook.
Basically PM seems to be populating the 'Email type' field in outlook with the recipient email address, replacing the required 'SMTP'.

Your specific problem, I haven't heard of before.  How about posting a screen shot of any windows or dialogs that illustrate the problem?

Use the 'Additional Options...' link to upload your screen shots.

Thanks,

-Kirk

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #3 on: September 20, 2010, 12:54:57 AM »
Appologies Kirk,

Was sure this issue had been mentioned by other users in this forum.
Screenies attached.

As you see from the 2nd image, PM seems to be populating 'E-Mail Type:' with the recepient email address, this results in Outlook refusing to send the email and returning an error.


Paul


[attachment deleted by admin]

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #4 on: September 20, 2010, 01:00:31 AM »
For reference...this is the error returned.



[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: PM 4.6.5...Send photo via email.....
« Reply #5 on: September 20, 2010, 08:07:50 AM »
Paul,

Appologies Kirk,

Was sure this issue had been mentioned by other users in this forum.
Screenies attached.

As you see from the 2nd image, PM seems to be populating 'E-Mail Type:' with the recepient email address, this results in Outlook refusing to send the email and returning an error.

PM is not setting the message type to anything (never has) and I suppose the latest Outlook versions don't like that.  I'll try clearing the field and see if it goes back to the default.

Are you willing to test a beta?

-Kirk

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #6 on: September 20, 2010, 08:33:38 AM »
Kirk,

More than happy to test the Beta.

Paul

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: PM 4.6.5...Send photo via email.....
« Reply #7 on: September 20, 2010, 09:15:42 AM »
Paul,

More than happy to test the Beta.

I'll see if I can get a beta made up today for you.

BTW, what happens if you press that "Internet Type" button next to the "E-mail type:" field in the "E-mail Properties" dialog?  Does the text change?  If so, what does it become?

Thanks,

-Kirk

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #8 on: September 20, 2010, 09:37:02 AM »
Kirk,

It becomes a Greyed out 'SMTP' Screenie attached again for reference.

Once I've changed that manually, the email will send, but, when sending 25 images, all as single emails, (which my paper require) it's increadibly time consuming.

Paul

[attachment deleted by admin]

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #9 on: September 21, 2010, 08:40:13 AM »
Kirk,

Any developments on this?

Paul

Offline jonathanpow

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #10 on: September 22, 2010, 05:58:19 AM »
Hello Paul and Kirk,

I have posted on this before and emailed support, but with no responses, so gave up. Kirk also responded to someone else with the same problem earlier this year.

See forum post (and my response at the bottom): http://forums.camerabits.com/index.php?topic=5029.msg23808#msg23808

To get round this problem I leave the address fields blank in Photo Mechanic and select the recipient for every message in Outlook. Although not ideal, for me it's quicker than setting the 'Email type' on each and every email.

Cheers,

Jonathan

Offline Peckachu

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: PM 4.6.5...Send photo via email.....
« Reply #11 on: September 22, 2010, 06:20:02 AM »
Jonathan,

Thanks for that, was sure I had seen the issue before.

Kirk,

For info, the Beta had no effect at all, still populating 'E-Mail Type' with the recipient address, Same effect if I move the recipient to the CC field.

Paul

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: PM 4.6.5...Send photo via email.....
« Reply #12 on: September 22, 2010, 06:38:51 AM »
Paul,

Thanks for that, was sure I had seen the issue before.

Kirk,

For info, the Beta had no effect at all, still populating 'E-Mail Type' with the recipient address, Same effect if I move the recipient to the CC field.

OK, well then I've exhausted all avenues that I can think of and have no idea why newer versions of Outlook decide to do what they're doing.  I am certainly not putting recipients in anything but the recipients array.

I added code to set the message type to "IPM.Note", whereas previously I left it blank which is what the documentation from Microsoft says you should do when you don't have a specific specialized message type.

-Kirk