Author Topic: Losing Star Ratings on RAW images in version 5  (Read 12672 times)

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Losing Star Ratings on RAW images in version 5
« on: September 05, 2012, 08:34:40 AM »
I am losing my star ratings within Photo Mechanic. I am accessing my images from a remote drive. It seems that when I set my star ratings on the images they randomly lose these ratings. For example last night I set a 4 star rating to 20 images, when I came back to Photo Mechanic this morning only 7 images had any ratings at all. Any help would be appreciated.

Cheers

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #1 on: September 05, 2012, 10:10:30 AM »
Please see:

http://forums.camerabits.com/index.php?topic=4688.0

...and add the additional information that I request each support message contain.

Thanks,

-Kirk

Offline judophotos

  • Full Member
  • ***
  • Posts: 238
    • View Profile
    • Judophotos
Re: Losing Star Ratings on RAW images in version 5
« Reply #2 on: September 05, 2012, 10:14:05 AM »
I am experiencing a similar problem with star ratings and colours not holding all the time.

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #3 on: September 05, 2012, 10:42:10 AM »
Sorry about that Kirk.

I am running Photo Mechanic Version 5.0, build 13217 (68ec133) on Mac OS x 10.7.4 on an Intel Mac. Like I said before, my images are being used from a shared drive on another computer (Running the same os if that's of use).

Thanks.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #4 on: September 05, 2012, 10:45:27 AM »
I am running Photo Mechanic Version 5.0, build 13217 (68ec133) on Mac OS x 10.7.4 on an Intel Mac. Like I said before, my images are being used from a shared drive on another computer (Running the same os if that's of use).

How are you setting the star ratings?  From the Contact Sheet?  IPTC Info dialog thumbnail?  IPTC Stationery Pad?  Preview window?

-Kirk

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #5 on: September 05, 2012, 10:46:23 AM »
I'm setting them from the contact sheet. Either by clicking on the stars or via the keyboard  command (depending on if my pointer is close to the image or not)

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #6 on: September 10, 2012, 06:08:42 AM »
Any ideas how to solve this?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #7 on: September 10, 2012, 06:36:10 AM »
Do all of the files on the remote volume have permissions that will allow you to modify them?

If you copy those same files to your local hard drive, do they then all retain their soft edits?

-Kirk

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #8 on: September 10, 2012, 07:39:58 AM »
Yes they seem to have retain the permissions. When I copy the files over locally, all the edits are still there. Just as an fyi, I do my edits in Capture NX2, if that might have any effect on the situation.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #9 on: September 10, 2012, 08:00:23 AM »
Yes they seem to have retain the permissions. When I copy the files over locally, all the edits are still there. Just as an fyi, I do my edits in Capture NX2, if that might have any effect on the situation.

Is Capture NX2 running at the time that you're having issues and is it browsing the folder you're working on?

Capture NX2 is notorious for keeping files open with exclusive access when browsing or editing images.

-Kirk

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #10 on: September 10, 2012, 09:42:05 AM »
Okay, that might be the issue then. I always close the file in CNX2 before going back to Photo Mechanic, but perhaps it's still holding onto the file's permissions for a second or two. Do you think that could be it?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #11 on: September 10, 2012, 10:34:11 AM »
Okay, that might be the issue then. I always close the file in CNX2 before going back to Photo Mechanic, but perhaps it's still holding onto the file's permissions for a second or two. Do you think that could be it?

Possibly.  Do you still have the browser portion of CNX2 open on the folder that you're also working with in PM?  Make the CNX2 browser 'look' at a different folder.

-Kirk

Offline slartyb

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • ShutterUP Studios
Re: Losing Star Ratings on RAW images in version 5
« Reply #12 on: September 10, 2012, 10:46:26 AM »
I keep the CNX2 browser closed. I just open my images directly from Photo Mechanic.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: Losing Star Ratings on RAW images in version 5
« Reply #13 on: September 10, 2012, 11:00:05 AM »
I keep the CNX2 browser closed. I just open my images directly from Photo Mechanic.

Just to rule out any interference from CNX2, quit it completely when you're done with it and want to continue to edit in PM.  Does that make any difference?

-Kirk

Offline Juerg

  • Sr. Member
  • ****
  • Posts: 259
    • View Profile
Re: Losing Star Ratings on RAW images in version 5
« Reply #14 on: September 10, 2012, 02:38:45 PM »
I keep the CNX2 browser closed. I just open my images directly from Photo Mechanic.

It does not matter if you have the CNX2 browser closed or not.

Assuming CNX2 is not running when you open a NEF file from within Photomechanic, CNX2 starts and it's browser is automatically pointed to the folder where this first opened file was located and "lock" all files in that folder (sometimes, most of the time) for any edits done thrue Photomechanic.

That is until you either close CNX2 again, or, that what I do, open the CNX2 browser and point it to an unused folder (I use the "desktop" by default).

Just to add, the above is on a Windows system, so it may be different on Mac.

And thinking about it, the above was true while using PM up to version 4.6.9. Since switching to version 5 (build 217) I did not have these permission issues with CNX2.
« Last Edit: September 10, 2012, 02:50:19 PM by archer69 »