Author Topic: Append feature in stationery pad not working.  (Read 9246 times)

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #15 on: August 19, 2014, 10:24:15 AM »
Well guess what, that doesn't help because the show info tooltips feature does not work when an iptc info field is open. Once you have the field open, when you hover over a photo in a contact sheet, the info text won't pop up anymore. It's a shame that having an iptc field open deactivates being able to do anything with the contact sheets.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #16 on: August 19, 2014, 10:37:49 AM »
If you want an automated "diff", I suggest using variables in the Text exporter template, and then use a "diff" utility.  Then you won't be eyeballing anything--the differences will be pointed out at you.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #17 on: August 19, 2014, 11:10:27 AM »
Going back to the append issue, I'm realizing now that in the previous version of PM, the caption field had a "+" box you could check, like some other fields still do have in PM5. In the old version, checking the "+" box when creating a template appended instead of overwriting when loading the template the way I do it -- via the load button while in the photo's iptc field.

With this new append/prefix button, I thought I would be gaining the prefix ability. Instead, I've lost the append ability, because the "+" box, which used to work, is now gone. No chance of you guys making this new append/prefix button work both ways? Checking the "+" button works both ways.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #18 on: August 19, 2014, 12:06:37 PM »
Going back to the append issue, I'm realizing now that in the previous version of PM, the caption field had a "+" box you could check, like some other fields still do have in PM5. In the old version, checking the "+" box when creating a template appended instead of overwriting when loading the template the way I do it -- via the load button while in the photo's iptc field.

With this new append/prefix button, I thought I would be gaining the prefix ability. Instead, I've lost the append ability, because the "+" box, which used to work, is now gone. No chance of you guys making this new append/prefix button work both ways? Checking the "+" button works both ways.

I'm not sure I understand you.  The popup menu for the Caption in the IPTC Stationery Pad allows you to Prefix, Replace, or Append.  A checkbox would be redundant/confusing.  Choosing Replace would be the same as having the old + check box unchecked, and choosing Append would be the same as having the old + check box checked.  Now there is a third capability (Prefix) that could not be represented with a single check box, thus it was removed.  No functionality was lost.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #19 on: August 19, 2014, 12:46:58 PM »
The new prefix/replace/append button works when using a template by first loading it to the pad and then applying the pad to an iptc field. The "+" checkbox in some other fields also works, appending the info that's in the template.

but:

Functionality is lost in PM5 (compared to old PM) when using a template by loading it into an iptc field with this method, which I will call the 2nd method: open a photo's iptc field / click "load" / choose a template and click open.

In old PM, I could use the "+" checkbox in the caption field to create a template that would append information when using the second method. In PM5, the prefix/replace/append button does not work when using the second method, so now I can no longer append in the caption field using the second method, I can only replace. (In PM5, those fields that still have the "+" checkbox also still append info using the second method.)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #20 on: August 19, 2014, 12:57:11 PM »
Correct.  It was never our intention to make IPTC Stationery Pad-generated files (IPT or XMP) be used as pseudo-IPTC Stationery Pads in the IPTC Info dialog.

I still think you'll find that doing a two-pass approach like I described earlier will be faster and less error-prone than the method you're missing from older versions of PM.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #21 on: August 19, 2014, 01:59:20 PM »
Having to first load a template to the pad, and then open the iptc field and apply it, is obviously slower than what I'm doing, and one is no more or less error-prone than the other. Indeed, I would think that the pad method is more error-prone, because you don't know for sure what template is loaded to the pad without checking first.

The apply stationery pad method is fine if you don't need to switch among several different templates on a frequent basis. My workflow requires switching templates on a frequent basis. Having to constantly open and close the pad every time I want to change templates would slow me down significantly.

My method accomplishes the same thing without ever having to open, load, and close the pad, then reopen the iptc field and apply the pad. I never have to close the iptc field as I go from photo to photo. That's not a pseudo-thing, it's a time-saving great thing! It will be faster for me to work around the loss of the append by copy/pasting the caption to a notepad, applying the template with the load button, and then pasting the caption back in, above the info that the template put in. That will be faster than changing the pad every time I need a different template. sigh.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #22 on: August 19, 2014, 02:28:09 PM »
Having to first load a template to the pad, and then open the iptc field and apply it, is obviously slower than what I'm doing, and one is no more or less error-prone than the other. Indeed, I would think that the pad method is more error-prone, because you don't know for sure what template is loaded to the pad without checking first.

The apply stationery pad method is fine if you don't need to switch among several different templates on a frequent basis. My workflow requires switching templates on a frequent basis. Having to constantly open and close the pad every time I want to change templates would slow me down significantly.

My method accomplishes the same thing without ever having to open, load, and close the pad, then reopen the iptc field and apply the pad. I never have to close the iptc field as I go from photo to photo. That's not a pseudo-thing, it's a time-saving great thing! It will be faster for me to work around the loss of the append by copy/pasting the caption to a notepad, applying the template with the load button, and then pasting the caption back in, above the info that the template put in. That will be faster than changing the pad every time I need a different template. sigh.

I'm not at all suggesting any of what you just posted.  Please re-read my suggestion post I made earlier this morning.  You make one pass through your images to categorize them and then one load/apply of each IPTC Stationery Pad.  It should be faster in the end.  Simply rating/color classing/typing a number in a field and then filtering on your categorization and applying a Stationery Pad should be much faster than pressing load on each image and choosing a file.

We won't be returning the functionality you're missing from PM 4.6.x in PM 5.

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #23 on: August 19, 2014, 03:01:40 PM »
Ok, gotcha, but what you're suggesting won't work for my workflow, so I was describing the only way I would be able to use the pad that would be viable for my workflow. I really can't do much with categorizing and filtering because nearly every photo requires a different work-up -- different information, different codes etc., in various iptc fields, all depending on the information I find once I open each photo's iptc field as I work through a folder. It's too individualized. Using the load button to add templates without ever leaving the iptc field, however, is great for my workflow, it's the only way that will really work for it.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #24 on: August 19, 2014, 03:15:53 PM »
Ok, gotcha, but what you're suggesting won't work for my workflow, so I was describing the only way I would be able to use the pad that would be viable for my workflow. I really can't do much with categorizing and filtering because nearly every photo requires a different work-up -- different information, different codes etc., in various iptc fields, all depending on the information I find once I open each photo's iptc field as I work through a folder. It's too individualized. Using the load button to add templates without ever leaving the iptc field, however, is great for my workflow, it's the only way that will really work for it.

You claimed earlier that you had few templates, somewhere around three in total.  I don't see how my method wouldn't work for you with such a limited set of IPTC Stationery Pads.  Have you tried my suggestion?

How are these IPTC Stationery Pads generated?

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #25 on: August 19, 2014, 03:49:06 PM »
I have 14 iptc templates (.xmp files) that I made. I typically will use 2 or 3 of them within any given folder of photos, and a folder can contain anywhere from 1 to 20 photos. But I use 10 to 14 of the templates at some point on any given day. There are so many differences from photo to photo in how the iptc fields must be filled out or changed, that, like I said, there is little I can do batch-wise. I also have to be able to skip back and forth amongst the photos in a folder as I'm working on them making changes and updates on the fly as the info we develop changes, and so then I have to re-edit what's in there. It's an atypical situation, I'm sure, compared to how PM is mostly used. (But not atypical for a news service.)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23226
    • View Profile
    • Camera Bits, Inc.
Re: Append feature in stationery pad not working.
« Reply #26 on: August 19, 2014, 04:31:09 PM »
I have 14 iptc templates (.xmp files) that I made. I typically will use 2 or 3 of them within any given folder of photos, and a folder can contain anywhere from 1 to 20 photos. But I use 10 to 14 of the templates at some point on any given day. There are so many differences from photo to photo in how the iptc fields must be filled out or changed, that, like I said, there is little I can do batch-wise. I also have to be able to skip back and forth amongst the photos in a folder as I'm working on them making changes and updates on the fly as the info we develop changes, and so then I have to re-edit what's in there. It's an atypical situation, I'm sure, compared to how PM is mostly used. (But not atypical for a news service.)

Have you tried using the popup menus that appear to the right of each of the fields and using them to insert the data you need?

-Kirk

Offline zeeman

  • Newcomer
  • *
  • Posts: 23
    • View Profile
Re: Append feature in stationery pad not working.
« Reply #27 on: August 19, 2014, 04:41:20 PM »
Sure, I use those for some situations.