Author Topic: PM+ Build 5560 Image preview generation hanging  (Read 5534 times)

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
PM+ Build 5560 Image preview generation hanging
« on: February 27, 2021, 12:06:00 PM »
I'm getting hangs when I run photo mechanic plus. it is still completing it's first full catalog ingest. The Metadata is indexed but the previews were taking much longer than expected. I checked what was going on and can see that it's no longer running this task. I've had no warning or notification to let me know that there's an issue though. I'd appreciate some help.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Build 5560 Image preview generation hanging
« Reply #1 on: February 27, 2021, 01:39:16 PM »
Adrian,

I'm getting hangs when I run photo mechanic plus. it is still completing it's first full catalog ingest. The Metadata is indexed but the previews were taking much longer than expected. I checked what was going on and can see that it's no longer running this task. I've had no warning or notification to let me know that there's an issue though. I'd appreciate some help.

What build of Photo Mechanic Plus are you running and what OS are you running it on?

-Kirk

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #2 on: February 27, 2021, 04:11:48 PM »
macOS 10.15.7. And build 5560.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Build 5560 Image preview generation hanging
« Reply #3 on: February 27, 2021, 06:04:58 PM »
Adrian,

macOS 10.15.7. And build 5560.

If you quit Photo Mechanic Plus and start it again, does the preview generation resume?

-Kirk

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #4 on: February 28, 2021, 01:44:09 AM »
Yes, then it stops again very shortly afterwards.

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #5 on: February 28, 2021, 03:35:35 AM »
The errors for the preview generation are happening to DNG files created by a stint testing Magic Lantern on my Canon 5D Mark II so could well be non standard. I'm trying to remove the directory from the catalog and see if the app starts working correctly after.

Possibly related, I'm sometimes seeing a notification when launching PM+. It's something like: "The dynamic subsystem failed to initialise."

And always seeing the following when quitting: "The Catalog system is taking awhile to stop. Continue waiting?" I click yes, but the question remains on the screen but is unresponsive. After awhile the question pane closes and an identical one appears. I click it and it becomes unresponsive again. This repeats a few times until the app finally quits.

I've managed to get the preview generation process going by removing the folder with these DNGs.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Build 5560 Image preview generation hanging
« Reply #6 on: February 28, 2021, 10:06:55 AM »
Adrian,

The errors for the preview generation are happening to DNG files created by a stint testing Magic Lantern on my Canon 5D Mark II so could well be non standard. I'm trying to remove the directory from the catalog and see if the app starts working correctly after.

Possibly related, I'm sometimes seeing a notification when launching PM+. It's something like: "The dynamic subsystem failed to initialise."

And always seeing the following when quitting: "The Catalog system is taking awhile to stop. Continue waiting?" I click yes, but the question remains on the screen but is unresponsive. After awhile the question pane closes and an identical one appears. I click it and it becomes unresponsive again. This repeats a few times until the app finally quits.

I've managed to get the preview generation process going by removing the folder with these DNGs.

Would it be possible to share a few of these files?

Thanks,

-Kirk

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #7 on: February 28, 2021, 03:28:38 PM »
I'd like to but is there a way to go back and see the logs from the files. Most of the files in the folder seemed to be ok from what I could see. But then every now and again it'd hit a bad one and quietly down tools. I don't want to send you one that it was happy with.

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #8 on: February 28, 2021, 03:43:53 PM »
Found it! Clipping of the error and the file in question are attached

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #9 on: February 28, 2021, 03:51:14 PM »
The image file won't preview in PM6 or PM6+ but it opens in Preview.app and Photoshop via ACR so it can't be all bad.

Offline FlyingLeopard.ch

  • Newcomer
  • *
  • Posts: 21
    • View Profile
    • Flying Leopard
Re: PM+ Build 5560 Image preview generation hanging
« Reply #10 on: February 28, 2021, 10:24:04 PM »
Hello Adrian
I had a similar problem, see my post "Catalog thumbnails preview takes very long and disappear again". My images are stored on a Synology NAS. Restarting PM+ didn't help, even restarting my Windows 10 PC. But after I restarted my Synology NAS, everything went as it should.

Regards,
Erich
www.FlyingLeopard.ch Aviation and Wildlife Photography

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #11 on: March 01, 2021, 02:53:46 AM »
I found it and read that you changed the folder names to something else then back again as well. The issue I had was with the files themselves I think. Hopefully CB can confirm what exactly the issue was. What seems to be the same is the experience when an ingest doesn't go well. And maybe this needs to be looked at so that the user isn't left scratching his or her head for days on end wondering if everything was ok or not, as I was.

FYI the folder in question was on a USB drive attached to a headless Mac mini which runs PM6+ from a catalog on an SSD separate from the main OS drive.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Build 5560 Image preview generation hanging
« Reply #12 on: March 01, 2021, 11:08:21 AM »
Adrian,

Found it! Clipping of the error and the file in question are attached

Thanks.  The DNG file does not have an embedded preview.  PM Plus won't be able to generate a preview from it.  But that shouldn't cause a hang, the file will just be ignored for preview purposes (metadata will still be gathered.)

-Kirk

Offline adrianlambert

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: PM+ Build 5560 Image preview generation hanging
« Reply #13 on: March 01, 2021, 01:18:24 PM »
Then are you able to make sense of the error I attached then if it's not due to the lack of embedded preview?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24688
    • View Profile
    • Camera Bits, Inc.
Re: PM+ Build 5560 Image preview generation hanging
« Reply #14 on: March 01, 2021, 01:37:01 PM »
Adrian,

Then are you able to make sense of the error I attached then if it's not due to the lack of embedded preview?

The error is due to the DNG file not having an embedded preview.  The preview cannot be generated.

-Kirk