Author Topic: PM6 on Mac - not functioning after using slideshow, options greyed out  (Read 1000 times)

Offline 00000000000

  • Newcomer
  • *
  • Posts: 4
    • View Profile
PM build 6738 (5753775) - Mac OS 13.2.1

Often after running a slideshow, switching to finder (e.g. to copy a file) and returning to the PM contact sheet, most menu options become greyed out.
(I can't take a screenshot while dropping down a menu)
The cursor initially disappears, but returns after clicking around.

Right clicking in the navigator - all options greyed out

The Photo Mechanic menu allows only "Services" - I have to force quit the app.
The File menu allows only "Open Recent", "Close Window", "Page Setup".
The Help menu allows only "Licensing"
etc

Command-L does not open the slideshow options; shift-command-L does not run the slideshow.

This previous post looks like the same issue: http://forums.camerabits.com/index.php?topic=14906


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24799
    • View Profile
    • Camera Bits, Inc.
PM build 6738 (5753775) - Mac OS 13.2.1

Often after running a slideshow, switching to finder (e.g. to copy a file) and returning to the PM contact sheet, most menu options become greyed out.
(I can't take a screenshot while dropping down a menu)
The cursor initially disappears, but returns after clicking around.

Right clicking in the navigator - all options greyed out

The Photo Mechanic menu allows only "Services" - I have to force quit the app.
The File menu allows only "Open Recent", "Close Window", "Page Setup".
The Help menu allows only "Licensing"
etc

Command-L does not open the slideshow options; shift-command-L does not run the slideshow.

This previous post looks like the same issue: http://forums.camerabits.com/index.php?topic=14906

Are you exiting the slideshow before you switch to the Finder or are you switching to the Finder while the slideshow continues to run?

-Kirk

Offline 00000000000

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Doing either has caused this issue

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24799
    • View Profile
    • Camera Bits, Inc.
Doing either has caused this issue

Sounds like the Slideshow hasn't quit.  It runs a modal event loop and that would explain the disabled menu items.  Perhaps it is running on another space that you can't see?  Have you tried switching spaces?

-Kirk

Offline 00000000000

  • Newcomer
  • *
  • Posts: 4
    • View Profile
I'm not using Spaces.
I can press ESC to return to the contact sheet and still have this problem.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24799
    • View Profile
    • Camera Bits, Inc.
I'm not using Spaces.
I can press ESC to return to the contact sheet and still have this problem.

For a problem like this, I suggest contacting our support folks at:

By email: support@camerabits.com

By phone: +1 503.547.2888

Hours: Mon-Fri, 9:00am-5:00pm [PST/PDT]

Offline 00000000000

  • Newcomer
  • *
  • Posts: 4
    • View Profile
OK, will do, thanks