Author Topic: IPTC date information not exporting from PM into Aperture 2  (Read 6605 times)

Offline robmunro

  • Newcomer
  • *
  • Posts: 5
    • View Profile
I use Photo Mechanic 4.6.4 with Aperture 2.1.4 on Intel MacBook with OS X v10.6.4.

Ever since I upgraded my MacBook to Snow Leopard, I seem to be unable to transfer the IPTC Date information, when I drag an image from PM into Aperture.  The date is definitely showing in PM and all the other Stationery Pad metadata gets transferred across except for the date.

I have tried changing settings in both PM and in Aperture but cannot get it to work for me. I would be really grateful for any assistance please.

Thanks, Rob.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24815
    • View Profile
    • Camera Bits, Inc.
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #1 on: June 21, 2010, 07:09:58 AM »
Rob,

I use Photo Mechanic 4.6.4 with Aperture 2.1.4 on Intel MacBook with OS X v10.6.4.

Ever since I upgraded my MacBook to Snow Leopard, I seem to be unable to transfer the IPTC Date information, when I drag an image from PM into Aperture.  The date is definitely showing in PM and all the other Stationery Pad metadata gets transferred across except for the date.

I have tried changing settings in both PM and in Aperture but cannot get it to work for me. I would be really grateful for any assistance please.

What file types have the problem?  RAW?  JPEG?  If RAW, are you embedding IPTC/XMP or are you using XMP sidecar files?

-Kirk

Offline robmunro

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #2 on: June 21, 2010, 11:29:35 AM »
Problems are with JPEG files, which is all I use for work.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24815
    • View Profile
    • Camera Bits, Inc.
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #3 on: June 21, 2010, 12:44:40 PM »
Rob,

Problems are with JPEG files, which is all I use for work.

If you could post a sample JPEG file, I'd be happy to take a look at it and see if it indeed contains a properly formatted IPTC Date/Time field.

Use the 'Additional Options...' link when you're composing your response.  It will allow you to upload a sample file.

-Kirk

Offline robmunro

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #4 on: June 22, 2010, 01:08:11 AM »
Sending again, as previous attempt failed. Two JPEGs attached for you - uncropped version is from PM and cropped version is from Aperture. This morning I seem to have somehow transferred the date info across into Aperture weirdly - I went into System Preferences -> Language & Text -> Formats yesterday and looked at settings but don't think I changed anything. Anyway this morning it seems to have resolved itself, but I would appreciate you having a quick look anyway just in case. Many thanks, Rob

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24815
    • View Profile
    • Camera Bits, Inc.
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #5 on: June 22, 2010, 07:10:28 AM »
Rob,

The first picture (uncropped) has a properly formatted IPTC date created field: 20100614
It also has a properly formatted IPTC time created: 114529+0000
It additionally has an XMP record in it that has the following tag: <photoshop:DateCreated>2010-06-14T11:45:29+00:00</photoshop:DateCreated>

The second picture (cropped) has a properly formatted IPTC date created field: 20100614
It is missing the IPTC time created field
It additionally has an XMP record in it, but it is missing the <photoshop:DateCreated> tag

I'm not sure why Aperture would drop that information since it is fairly important to know the time as well as the date, but it is definitely missing even though it was present in the original file captioned by Photo Mechanic.

-Kirk

Offline robmunro

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #6 on: June 22, 2010, 01:01:48 PM »
Thanks Kirk. Is there anything I can do to resolve this, do you think? Any settings I should look at?  By the way, I never use Photoshop, so interested why there is a Photoshop tag in there. Can you explain that please? At least now I have got the date that's something, but only got there by chance really!! Cheers, Rob

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24815
    • View Profile
    • Camera Bits, Inc.
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #7 on: June 22, 2010, 01:42:13 PM »
Rob,

Thanks Kirk. Is there anything I can do to resolve this, do you think? Any settings I should look at?  By the way, I never use Photoshop, so interested why there is a Photoshop tag in there. Can you explain that please? At least now I have got the date that's something, but only got there by chance really!! Cheers, Rob

Adobe created XMP and in creating photo specific XMP tags created an XML namespace for Photoshop.  In order to be compatible with Adobe's applications, PM creates those exact same tags.

I'd check your settings in Aperture.  You might also find an Aperture-related forum and ask there as well.  Aperture shouldn't be dropping any IPTC information, even if it doesn't understand or edit it.  All information should be preserved in IPTC and XMP metadata.

-Kirk

Offline robmunro

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: IPTC date information not exporting from PM into Aperture 2
« Reply #8 on: June 22, 2010, 01:48:08 PM »
Thanks Kirk - I appreciate your help. Best, Rob