Author Topic: Build 5716 bug ?  (Read 4955 times)

Offline hsaphoto

  • Member
  • **
  • Posts: 67
    • View Profile
Build 5716 bug ?
« on: March 26, 2021, 07:47:53 AM »
Hello at PM,

one of my colleague (not so fluent in english) updated his PM6 to v.5716 this morning and since then his .CR2 files are corrupted on tag or color class change. He can't open his files in PS.

He will later send my screen grabs as he is on an assignent now. 

I did send him via WeTransfer v.5560 I had on my hd, hopefully he can install it on top of v.5716.

Thanks,


Hugo

photojournalist,
La Presse, Montreal, Canada.
www.lapresse.ca


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24278
    • View Profile
    • Camera Bits, Inc.
Re: Build 5716 bug ?
« Reply #1 on: March 26, 2021, 08:39:47 AM »
Hugo,

one of my colleague (not so fluent in english) updated his PM6 to v.5716 this morning and since then his .CR2 files are corrupted on tag or color class change. He can't open his files in PS.

He will later send my screen grabs as he is on an assignent now. 

I did send him via WeTransfer v.5560 I had on my hd, hopefully he can install it on top of v.5716.

Unfortunately your colleague's experience has been confirmed by others.  We have pulled the 5716 build.  The old build can certainly be reinstalled.

All of the builds are accessible here: http://forums.camerabits.com/index.php?board=15.0

-Kirk

Offline IanCharles

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Build 5716 bug ?
« Reply #2 on: March 26, 2021, 01:12:55 PM »
It was also on .NEF files too in case you weren't aware.

I've reinstalled Build 5660 which has worked fine.

Offline hsaphoto

  • Member
  • **
  • Posts: 67
    • View Profile
Re: Build 5716 bug ?
« Reply #3 on: March 26, 2021, 01:16:26 PM »
Thank you Kirk for the follow up, hope you can fix this without too much trouble.

Re-installing a prior build worked without a hitch.



HSA

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24278
    • View Profile
    • Camera Bits, Inc.
Re: Build 5716 bug ?
« Reply #4 on: March 26, 2021, 01:35:05 PM »
Ian,

It was also on .NEF files too in case you weren't aware.

I've reinstalled Build 5660 which has worked fine.

It affected any TIFF-based RAW file.  NEF, CR2, DNG, etc.

A fix is in the works, but we're going to seed the build out to outside testers before the next release.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24278
    • View Profile
    • Camera Bits, Inc.
Re: Build 5716 bug ?
« Reply #5 on: March 27, 2021, 08:14:59 AM »
Anyone who has the 5716 build is encouraged to go back to build 5560 which is now the current build when checking for updates and is available from the downloads page on our website or you can get any previous build from the Announcements board on this forum.

https://home.camerabits.com/downloads/
http://forums.camerabits.com/index.php?board=15.0

Damaged files can be repaired by installing the 5560 build, selecting the damaged images, and then using the "Revert TIFF-based RAW to Original" command on the Tools menu.

-Kirk

Offline Kevin M. Cox

  • Sr. Member
  • ****
  • Posts: 472
  • PM 6 (6645) | macOS 12.6.1
    • View Profile
    • Kevin M. Cox | Photojournalist
Re: Build 5716 bug ?
« Reply #6 on: April 05, 2021, 01:18:03 PM »
Just as a datapoint: One of our staffers got bit by this over the weekend. Glad the solution is easy enough.
Kevin M. Cox | Photojournalist
https://www.KevinCox.com

Offline ericbowles

  • Newcomer
  • *
  • Posts: 36
  • Professional Photographer
    • View Profile
    • Bowles Images
Re: Build 5716 bug ?
« Reply #7 on: April 20, 2021, 10:41:56 AM »
I had to roll back to 5560 today. 

I'm running PM 6 on Windows 10 - and everything is the current versions.

I was unable to write a watermark when using the Save As function.  I have several variables in my watermark.  After rolling back to 5560 successfully, I had no problem applying the watermark.
Eric Bowles

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24278
    • View Profile
    • Camera Bits, Inc.
Re: Build 5716 bug ?
« Reply #8 on: April 20, 2021, 11:04:46 AM »
Please see: http://forums.camerabits.com/index.php?topic=14120.0

We have released a new build that no longer has the problem that build 5716 had in it and it has a number of improvements over build 5560.

-Kirk

Offline Kevin M. Cox

  • Sr. Member
  • ****
  • Posts: 472
  • PM 6 (6645) | macOS 12.6.1
    • View Profile
    • Kevin M. Cox | Photojournalist
Re: Build 5716 bug ?
« Reply #9 on: April 20, 2021, 11:30:59 AM »
Thanks Kirk.
Kevin M. Cox | Photojournalist
https://www.KevinCox.com

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Build 5716 bug ?
« Reply #10 on: April 28, 2021, 12:08:46 PM »
Have been very busy lately so wasn't paying attention to the forums much. As a result, I just got bitten by this bug using PM6 plus build 5716 :(
Sadly there's no update for PM6 Plus yet though (or otherwise I would not have been bitten by the bug; I still keep my SW up to date, which in this case was a bad thing…) Any idea as to when PM6 Plus gets updated too?
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24278
    • View Profile
    • Camera Bits, Inc.
Re: Build 5716 bug ?
« Reply #11 on: April 28, 2021, 12:27:44 PM »
Hayo,

Have been very busy lately so wasn't paying attention to the forums much. As a result, I just got bitten by this bug using PM6 plus build 5716 :(
Sadly there's no update for PM6 Plus yet though (or otherwise I would not have been bitten by the bug; I still keep my SW up to date, which in this case was a bad thing…) Any idea as to when PM6 Plus gets updated too?

Probably next week for an official build.  But in the interim you can use this build:

http://forums.camerabits.com/index.php?topic=14093.0

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2550
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Build 5716 bug ?
« Reply #12 on: April 28, 2021, 11:37:31 PM »
Thanks!
Probably next week for an official build.  But in the interim you can use this build:
http://forums.camerabits.com/index.php?topic=14093.0

Excellent, thanks!

(I really should be spending more times in the forums, but alas, I'm swamped with work…)
Hayo Baan - Photography
Web: www.hayobaan.nl